FlightCtrl Nueva Placa de control Rabbit Flight

Discussion in 'Rabbit' started by igc23, Dec 27, 2011.

  1. AntonZ Miembro

    AntonZ
    Joined:
    May 18, 2010
    Messages:
    516
    Likes Received:
    0
    Gracias miniplanes. Me estaba dejando los ojos buscando donde estaba...
    Un saludo
     
  2. luis poza Miembro

    luis poza
    Joined:
    Sep 12, 2008
    Messages:
    143
    Likes Received:
    1
    Gracias a todos:sad::sad:
    lo probare cuando salga la placa de la UVI

    yo ni se armann los motores

    alguno recuerda como hacer un reset hard?
     
  3. AntonZ Miembro

    AntonZ
    Joined:
    May 18, 2010
    Messages:
    516
    Likes Received:
    0
    Hola Luis
    Te refieres a esto??
     
  4. miyuti Nuevo Miembro

    miyuti
    Joined:
    Apr 6, 2012
    Messages:
    14
    Likes Received:
    0
    Yo también tengo los fastidiosos microcoortes y este condensador es mi última esperanza ya que lo he intentado todo.
    Donde lo podría comprar???
    otra duda, es 3300yF/6.3V ó 3300uF/6.3V???
     
  5. Miniplanes Miembro Activo

    Miniplanes
    Joined:
    Mar 28, 2007
    Messages:
    1,743
    Likes Received:
    0
    es la misma cosa !!!

    saludos
     
  6. luis poza Miembro

    luis poza
    Joined:
    Sep 12, 2008
    Messages:
    143
    Likes Received:
    1
    ya vive de nuevo , gracias foro:rolleyes2:

    hoy oruebo lo del condensador:redface: a ver que tal aunqie el que tengo es de menor capacidad , y fallamos , empiezo con quitar las alimentaciones de los BEC , es un poco mas duro...:eek:hmy:

    ya os cuento
     
  7. luis poza Miembro

    luis poza
    Joined:
    Sep 12, 2008
    Messages:
    143
    Likes Received:
    1
    por cierto , siempre que hgais pruebas o cambieis el firware etc... quitar las helices, , el restulado ha sido 2 puntos en un dedo , para empezar bien el año , me dan PUNTOS, en vez de quitarlos...:tongue2:
     
  8. supercanii Moderator

    supercanii
    Joined:
    Mar 12, 2008
    Messages:
    4,416
    Likes Received:
    1
    Luis... eso de quitar las hélices (en mi caso mas que quitar las aflojo para que queden libres) es algo que hago de forma estricta luego de cada actualización y/o cambio importante después de un pequeño "salto" que hizo mi cuad sin previo aviso y sin venir a cuento...

    Bueno empezaste el año bien... con un par de puntos extras y reviviendo la Rabbit. lo de más es cuento....
     
  9. luis poza Miembro

    luis poza
    Joined:
    Sep 12, 2008
    Messages:
    143
    Likes Received:
    1
    Prueba de hoy :

    - receptor alejado de la placa lo que me permite el cacharro
    - condensador de 1200yf y 10 V que tenia por casa ,

    efecto : ha mejorado pero he tenido un par de sustos , el efecto era parecido a una estabilización , es decir , un par de sstos seguidos y luego perfecto durante 4 minutos

    Miniplanes , ¿piensas que el condesador es pequeño?
     
  10. Miniplanes Miembro Activo

    Miniplanes
    Joined:
    Mar 28, 2007
    Messages:
    1,743
    Likes Received:
    0
    hola Luis, dime como llevas la alimentacion de tu Rabbit ? la alimentas con un BEC separado o utilizas uno de los de los variadores, o todos a la vez conectados en los pins de salida ?

    Yo por norma, pongo un BEC por separado y lo respectivo condensador de 3300yF, saco todas las salidas de alimentacion (+5v) de cada uno de los variadores y no las utilizo(estan desligadas y isoladas).

    Hasta ahora todo sin problema en mis controladoras, en lo que toca a los microcortes, certifica-te que los variadores son buenos, es decir que trabajan por lo menos hasta los 400hz, ya que la Rabbit, para se poder volar bien tiene que tener 330Hz configurados.

    saludos
     
  11. luis poza Miembro

    luis poza
    Joined:
    Sep 12, 2008
    Messages:
    143
    Likes Received:
    1
    llevo todos los BEC conectados , presiento que eso es foco de problemas

    bueno primero voy a poner un condensador mas tocho , si esto falla , quitaré 3 de los BEC y si esto falla pondré un BEC independiente

    :worthy:

    eso si hay que esperar al finde mañana empezamos a currar de nuevo :plane:

    buena semana a todos...
     
  12. Miniplanes Miembro Activo

    Miniplanes
    Joined:
    Mar 28, 2007
    Messages:
    1,743
    Likes Received:
    0
    Luis, te lo garantizo yo, eso es la fuente de tus problemas, tuve una mala experiencia una vez y averigue con el oscilo que la cantidad de ruido que es generada en la controladora es proporcional a lo numero de variadores que uno lleva conectado de esa manera, no hay condensador que te valla... remove los pin de 5v cuanto antes....y verás que no tendras mas problemas...."just my 2 cents" !!!

    saludos
     
  13. diafragma1939 Miembro

    diafragma1939
    Joined:
    Jan 5, 2012
    Messages:
    550
    Likes Received:
    0
    Boas

    Es que la gente no lee ni las respuestas a sus propias preguntas...

    Eso ya lo he comentado yo hace unos cuantos POST y te garantizo casi al 100% que el problema viene de la calidad de los ESC, y su velocidad máxima de refresco, así como el exceso de BECs conectados a la placa. A mas de uno nos ha pasado justo esto de los microcortes.

    Ciao
    :plane:
     
  14. Manolo_B Maestro FPV

    Manolo_B
    Joined:
    Jan 26, 2012
    Messages:
    2,360
    Likes Received:
    1
    Empieza por ahí y ahorra tiempo y disgustos.
     
  15. fenestrone Nuevo Miembro

    fenestrone
    Joined:
    Feb 3, 2012
    Messages:
    96
    Likes Received:
    0
    buenas, a probado alguien el modulo nuevo de mag+ barometro de precision? se`puede montar en las placas viejas? se nota la diferencia? y lo ultimo y mas inportante, donde se puede comprar?

    de no haberlo probado nadie me comprometo a hacer de conegito de indias, ya que a mi baro actual se le va la castaña cada 2 segundos
     
  16. luis poza Miembro

    luis poza
    Joined:
    Sep 12, 2008
    Messages:
    143
    Likes Received:
    1
    ya he quitado los +5vv y puesto un BEC independiente , mañana la gran prueba

    :ansioso:
     
  17. danybd Miembro

    danybd
    Joined:
    Apr 26, 2010
    Messages:
    123
    Likes Received:
    0
    Ayuda GPS Rabbit

    Hola a todos;
    Hoy he montado el GPS que he adquirido por separado en la rabbit, pero no consigo que funcione. En el software no varia los dos valores que corresponden al GPS, siempre estan a 0. He probado en el exterior para descartar problemas de cobertura y tampoco lee ningun valor, y volando, al activar el lock position tampoco mantiene la posicion. La rabbit detecta el GPS porque enciende el led correspondiente al GPS. Podriais decirme si necesito realizar alguna calibracion especial o deberia funcionar directamente con activar en el software la opcion de GPS e instalarlo en la rabbit. Por si sirve de algo tengo instalado el barometro MS5611 con la resistencia de 10k que necesita para funcionar.

    Muchas gracias por vuestra ayuda.
     
  18. sergio sanchez Miembro Activo

    sergio sanchez
    Joined:
    Jul 19, 2009
    Messages:
    1,031
    Likes Received:
    0
    A ver si te contestan ati porque to tengo el mismo problema :sad:
     
  19. sergio sanchez Miembro Activo

    sergio sanchez
    Joined:
    Jul 19, 2009
    Messages:
    1,031
    Likes Received:
    0
    Manolo entonces aconsejas conectar solo un bec a la placa rabit?? Yo tengo los 6 becs conectados a la placa y no me a dado ningun problema(que no quiere decir que no me valla a dar) entonces quedaria tal que asi:

    Por ejemplo:motor 1 en este canal de placa conecto el bec del variador,

    2,3,4,5,6 ¿que conecto blanco y negro?o solo el blanco(señal)en la placa de dichos canales?
     
  20. danybd Miembro

    danybd
    Joined:
    Apr 26, 2010
    Messages:
    123
    Likes Received:
    0
    Tienes que conectar solo un bec de uno de los esc, es decir, un esc debes conectarlo a traves de todos sus cables (rojo, blanco y negro) el resto necesita solo el blando de la señal del canal y el negro de masa. Si los conectas todos es como si conectases fuentes conmutadas en paralelo; la regulacion que hace el BEC para conseguir una tension determinada puede verse afectada al conectarle otra fuente conmutada en paralelo pudiendo llegar a quemarsete algun bec por sobrecalentamiento. Con conectar un bec solo de un esc es sufiente, al resto le sacas el cable rojo y asi ya no conectas fuentes en paralelo.
    Saludos.
     
  21. danybd Miembro

    danybd
    Joined:
    Apr 26, 2010
    Messages:
    123
    Likes Received:
    0
    Tambien te pasa lo mismo? Es curioso por la placa lo reconoce, pero es como si no consiguiese recibir la señal gps. Tu GPS tiene la antena separada o tiene todo junto dentro de una funda termoretatil transparente? El mio es el compacto (con funda termoretatil transparente) supongo que esto no afectara negativamente a la señal.
    En fin, a ver si alguien nos puede decir algo.
    Saludos.
     
  22. diafragma1939 Miembro

    diafragma1939
    Joined:
    Jan 5, 2012
    Messages:
    550
    Likes Received:
    0
    Boas

    El problema del GPS nos ha pasado a muchos, la solución más habitual pasa por conectar el Tx del GPS con el Rx de la placa y el Rx del GPS con el Tx de la placa, en resumen cruzar los cables. Normalmente esto soluciona los problemas… Además como podeis ver en las fotos del siguiente POST yo tengo la antena del GPS casi pegada a la IMU separando la sólo mediante un escudo típico de MK… y con esta configuración pillo, en menos de 1 minuto, entre 8 y 12 satelites…

    Ciao
    :plane:
     
  23. diafragma1939 Miembro

    diafragma1939
    Joined:
    Jan 5, 2012
    Messages:
    550
    Likes Received:
    0
    Boas

    No hace falta inutilizar ningún cable solo metes el conector de manera que conecte solo el pin blanco con la placa en el sitio adecuado.

    Ciao
    :plane:
     

    Attached Files:

  24. diafragma1939 Miembro

    diafragma1939
    Joined:
    Jan 5, 2012
    Messages:
    550
    Likes Received:
    0
    Boas

    El módulo en cuestión es este http://www.goodluckbuy.com/hmc5883l...sor-compass-barometric-pressure-module-.html… pero el proceso de sustitución no se limita a cambiar uno por otro además hay que soldar una resistencia, creo que recordar de 10k, de esas planas tipo micro-transistor… vamos trabajito de experto… además de resetear la plca y volver a instalar firm…etc…

    Las ventajas si el antiguo baro esta bien configurado y cuentas ademas con la esponjita de cobertura y una buena antena GPS como esta http://rctimer.com/index.php?gOo=goods_details.dwt&goodsid=763&productname= mucho mejor y más barata que la propia de la Rabbit, las ventajas de un baro sobre otro son más bien pocas…

    Ciao
    :plane:

    Nota bene: Te vale más la pena comprar la Rabbit con el baro nuevo que comprar lo e instalar lo tú… después de todo la diferencia de precio entre la que trae el nuevo y el viejo es más bien poca…
     
  25. luis poza Miembro

    luis poza
    Joined:
    Sep 12, 2008
    Messages:
    143
    Likes Received:
    1
    foro, prueba superada ... 2 vuelos y ningun fallo:biggrin2:

    Respecto a GPS haz caso a Diafragma a mi me ocurria tambien y cruce tx y RX y solucionado

    bueno ya os diré los vanaces , ya que ahora tengo que aprender como sar el RTH y el Hold de altura que no lo hace bien,

    ¿alguien sabe como se fija las coordenadas del GPS para que al darle al switch del RTH vuelva?

    lo dicho mil gracias
     
  26. diafragma1939 Miembro

    diafragma1939
    Joined:
    Jan 5, 2012
    Messages:
    550
    Likes Received:
    0
    …si es que lo que no me haya pasado a mi… aunque lo de un sólo ESC se ha comentado hasta la saciedad en RCG…

    …lo digo por conocimiento empírico como diría el amigo aeroplano…

    Lo de la vuelta a casa es algo más delicado ya que depende casi exclusivamente de la cantidad de satélites que tenga fijados antes del despegue… cuantos más satélites mejores posibilidades de vuelta a casa… se aconseja dejar que se estabilice la captura de satélites antes de despegar… eso quiere decir unos 5 minutos con el GPS propio de la Rabbit y aprox. un minuto con el de la Crius que he comentado antes… aunque también se puede mejorar alejando la antena de todas las interferencias y/o poniendo un escudo tipo MK como el que utilizo yo… Para saber si la captura se ha estabilizado nada como utilizar un OSD como el Remzibi que comparta la antena GPS de la Rabbit de esta manera sabrás exactamente cuando se ha estabilizado la captura de satelites, ya que el OSD en pantalla dejara de variar…

    Ciao
    :plane:
     
  27. danybd Miembro

    danybd
    Joined:
    Apr 26, 2010
    Messages:
    123
    Likes Received:
    0
    Hay una configuracion de cables RX y TX de las dos posibles, en la que la placa directamente no reconoce el GPS y se queda haciendo "el coche fantastico" de forma permanente, por lo que entiedo que no consigue comunicar con el GPS. De la otra forma posible, enciende el LED de GPS y pasa a modo espera. Lo unico que se me ocurre es que no espere el suficiente tiempo a que localize los satelites o que la antena esté demasiado pegada a la tarjeta GPS. Por otro lado, hay alguna forma de saber los satelites que esta cogiendo en cada momento.
    Gracias.
    Saludos.
     
  28. luis poza Miembro

    luis poza
    Joined:
    Sep 12, 2008
    Messages:
    143
    Likes Received:
    1
    Ayer 2 bateris y 1 fallo, uff :cool:

    bueno a ver si alguin me ayuda a decirme que es cada parametro, ya que lo estoy cambiando a prueba y acierto

    esta es la configuracion que llevo
     

    Attached Files:

  29. franfrio Miembro

    franfrio
    Joined:
    Apr 18, 2009
    Messages:
    169
    Likes Received:
    0
    Rabbit va a botes en altitud automática

    Hola tengo un hexa y no consigo que mantenga altitud y menos bloqueo ni posición GPS
    Y ando muy perdido con los parámetros de configuración.
    Si alguno me explica que son los siguientes parámetros de la pestaña BASIC SETUP
    1 rabbit%20basic%20setup.JPG

    stavili level ... esto es estabilidad de nivel, cuando se aplica y en que modalidad.
    Aux stavility ...auxiliar estabilidad, mismas dudas.
    Dyna stavility... esto creo que es estabilidad dinámica creo, para que sirve
    Balance L....balance L no sé lo que es L ni a que se aplica
    Aux balance... auxiliar de balance no se si es de L y lo mismo ni idea.
    yaw staviliti.... ni idea
    Yaw lock.... bloqueo de algo
    hight loock... lo mismo bloqueo alto de no se que
    aux H look....
    height Stabiliti...

    2 rabbit%20custom%20monitor.JPG

    Si pongo el interruptor del canal 5 en posición H ósea Height loock bloqueo de altitud el aparato da botes y no mantiene la altitud ni a menos ni a mas de 2000mm vamos ni barométrica ni con sonar.
    En el canal 6 tengo seleccionado posición H conmutador 3 posiciones, mantenimiento de posición y se va donde le sale.
    Mismo canal posición L retorno a casa, go home y hay ya ni sé lo que hace.
    No sé donde meto la pata es caso es que en vuelo sin automatismos va de cine pero no aplica ningún automatismo correctamente. Si me echáis una mano os lo agradezco. Saludos Fran
     
  30. diafragma1939 Miembro

    diafragma1939
    Joined:
    Jan 5, 2012
    Messages:
    550
    Likes Received:
    0
    Boas

    Los valores por defecto en base al tamaño del frame seleccionado deberían funcionar correctamente casi en un 99 % de los casos con muy ligeras variaciones en casos contados. Con lo cual si has seleccionado correctamente el tamaño de tu chasis y su configuración (Quad, hexa, Y6…o lo que sea) estos parámetros no deberías en absoluto tener que modificarlos.

    Naturalmente deberías también hacer tus calibraciones tanto horizontal como de magnetómetro, además de cubrir con una pequeña pieza de esponja o algo similar que permita el paso del aire la tarjetita donde va el barómetro.

    En la pestaña "Basic setup" y si te encuentras en la España peninsular deberías poner en el apartado de declinación magnética un -1.

    Luego en la pestaña de "Custom monitor" deberías activar la autoestabilidad y el PTZStab (si tienes un gimbal conectado a la IMU) en todas las posiciones de ambos canales salvo que vayas a hacer vuelo 3D.
    En el canal y en la posición que desees tener mantenimiento de altura deberías activar además del" HeightLock" el "PositionHold".
    En el canal y la posición donde desees la vuelta a casa, salvo que el de 3 posiciones lo tengas siempre en la posición neutra yo pondría el "GoHome" y el "HeightLock" (además del "autoStabi" y el "PTZStab") en la posición media del interruptor de 3 posiciones y el "AutoLanding" en la posición alta de ese mismo interruptor… dejando la posición baja sin nada más que la autoestabilidad activada.

    Con todo esto estoy suponiendo que has programado correctamente tu radio para estas posiciones de interruptor…etc…etc. Y que además respetas las distancias entre los ESC y el magnetómetro, retuerces todos los cables de señal/alimentación de los ESC (Con el objeto de evitar en la medida de lo posible ruidos/interferencias magnéticas), que alimentas la placa desde un solo ESC/BEC y que mantienes tu antena de GPS a una distancia mínima aconsejada de unos 15 cm. por encima de la IMU (O en su defecto tienes un escudo de GPS como los MK).

    Ciao
    :plane:

    Nota bene: Por cierto has comprobado que la luz del GPS se enciende y se mantiene cuando arrancas la aplicación lo digo por que en la Longitud y latitud creo que deberían figurar cifras distintas de las que tienes. Además veo que no tienes activado el "CareFree" en ninguna posición…Why…? En cuanto a los parámetros que afectan realmente al comportamiento del GPS y por lo tanto al "PositionHold" y el "GoHome" están en la pestaña GPS Setup donde en algunos casos hay que toquetear un par de cosas dependiendo de la configuración del equipo.
     
  31. franfrio Miembro

    franfrio
    Joined:
    Apr 18, 2009
    Messages:
    169
    Likes Received:
    0


    Lo primero muchas gracias por dedicarme tu tiempo.
    Los valores por defecto en base al tamaño del frame seleccionado deberían funcionar correctamente casi en un 99 % de los casos con muy ligeras variaciones en casos contados. Con lo cual si has seleccionado correctamente el tamaño de tu chasis y su configuración (Quad, hexa, Y6…o lo que sea) estos parámetros no deberías en absoluto tener que modificarlos.

    Los valores por defecto ya los puse y no consigo nada, en vuelo normal sin automatismos va bien.
    Es un Hexa de de 555mm entre ejes de motor y lo puse en (Default:(450£­650]mm Frame»ú¼ÜÊý¾Ý)

    En la pestaña "Basic setup" y si te encuentras en la España peninsular deberías poner en el apartado de declinación magnética un -1.
    Gracias esto no lo savia ya lo puse en 1. La calibración de horizontal, magnetómetro ya la hice un montón de veces.
    En el canal y la posición donde desees la vuelta a casa, salvo que el de 3 posiciones lo tengas siempre en la posición neutra yo pondría el "GoHome" y el "HeightLock" (además del "autoStabi" y el "PTZStab") en la posición media del interruptor de 3 posiciones y el "AutoLanding" en la posición alta de ese mismo interruptor… dejando la posición baja sin nada más que la autoestabilidad activada.
    Esto si me envías una captura de pantalla me aclarare mejor,
    rabbit configuracion 450-650.JPG
    Por cierto me llama la atención que si pongo DATA DISPLAY observo que en la casilla UL_HEIGTH oscila muy poco entre dos o tres mm pero en la casilla BA_HEIGTH dm
    Que no sé lo que quiere decir dm puede ser decimal metro oscila mucho si son metros
    Ejemplo de 473 dm a 464 dm
    Tengo una espuma en el modulo barométrico.
    IMG_0779.jpg
    Te pongo una foto.
    Con respecto al GPS va bien en el exterior claro en un minuto da lectura longitud latitud
    Y si le doy a la palanca de gas a la izquierda me da de dos a tres led encendidos, eso en la ventana de casa.
    La radio está bien configurada se mueven bien los valores de las posiciones de los interruptores Y conmutador
    el carefre lo tenía en el canal 7 pero lo quite al añadir el gimbal pues en ese canal esta el gimbal de cabeceo, y sería un lio en el mismo canal una maniobra de irruptor.
    En el canal 8 no sé porque no aparecen datos de entrada pulsos pero en salida funciona bien el canal 8 para el gimbal de alabeo, solo que como no reconoce la entrada no puedo hacer regulaciones y está bien configurada si lo pongo a servo directo va perfecto.
    Gracias por tu ayuda te pasó un privado con mi móvil para que me eches una mano por WhatsApp si te es posible, Saludos Fran
     
    #1931 franfrio, Jan 15, 2013
    Last edited: Jan 15, 2013
  32. danybd Miembro

    danybd
    Joined:
    Apr 26, 2010
    Messages:
    123
    Likes Received:
    0
    Hola franfrio;

    Yo tengo problemas con el GPS, para ser exacto no consigo que me ponga valores distintos del 0,000. Me podrías decir como te inicia a ti el GPS.

    Cuando yo enciendo la rabbit, empieza con los LED´s a hacer "el coche fantastico" y va encendiendo los LED´s correspondientes a cada modulo que tengo instalado, y el de GPS tambien lo enciende. Esto lo hace en aproximadamente 5segundos (no creo que en 5 segundos localize los satelites) luego pasa al modo respiracion para poder activar la placa. Si le doy a la palanca del gas no me enciende ningun led. Tengo entendido que si no localiza satelites no pasa al modo respiracion, ¿es cierto esto? El LED que incorpora el GPS, de color rojo, está encendido en todo momento.
    Gracias de antemano por tu ayuda.
     
  33. franfrio Miembro

    franfrio
    Joined:
    Apr 18, 2009
    Messages:
    169
    Likes Received:
    0
    Bueno si estas bajo techo en casa y no desconectas el GPS físicamente quitándole solo un polo de alimentación o desmarcas la casilla GPS receiver nunca pasa al modo latente, pues espera a obtener satélites, creo que esto lo sabrás ya, método que utilizo con GPS conectado en exterior
    y pestaña activada, conectar alimentación o no si lo tienes mediante USB no hace falta enciende la radio, mueve una vez la palanca de cabeceo arriba o la palanca alabeo, pita una vez, los led de la placa oscilan de izquierda a derecha, el led de alimentación del GPS permanece fijo siempre que este alimentado, espera a que entre en modo latente, led placa principal parpadean en secuencia de unión de derecha a izquierda,esto está mal puesto parpadean todos juntos una vez por segundo modo latente. si tienes el software abierto conectado el USB pulsas la pestaña de data display tiene que aparecerte longitud y latitud valores numérico. si le das a la palanca de gas abajo y a la izquierda ya en modo latente se tiene que enciendes un led de la placa principal izquierda eso es que ya capturo 6 satélites y a medida que captura mas se van encendiendo mas led uno por cada satélite por encima de 6, eso entendí en el manual. De no ser así algo tienes mal, ha se me olvidaba para salir del modo indicación numero de satélites vuelves a mover la misma palanca de dirección izquierda. Espero que te sirva. Saludos Fran.
     
    #1933 franfrio, Jan 15, 2013
    Last edited: Jan 20, 2013
  34. danybd Miembro

    danybd
    Joined:
    Apr 26, 2010
    Messages:
    123
    Likes Received:
    0
    Gracias Fran,

    Ya he consiguido arrancar el GPS, solo tuve que cruzar RX, TX y tener algo mas de paciencia esperando a que localizase algún satélite. He conseguido que localizase un satelite, creo que la ubicación del receptor GPS no es del todo buena, le buscaré una nueva ubicación para mejorar la recepcion. Ahora mismo llueve y no puedo probar el hold position, pero al menos ahora enciende un led en test de satelites. Tan pronto como el tiempo lo permita, pruebo el GPS a ver si me funciona y posteo los resultados. Tambien tengo modulo de ultrasonidos y barometro + magnetometro que he soldado a posterior junto con la resistencia de 10k que necesita para que su correcto funcionamiento; me funciona todo perfectamente. Si te puedo ayudar con algo aquí estoy.

    Muchas gracias!!!!
     
  35. danybd Miembro

    danybd
    Joined:
    Apr 26, 2010
    Messages:
    123
    Likes Received:
    0
    Hola Fran;

    Supongo que las unidades "dm" serán decímetros donde 1dm=10cm=100mm.

    Saludos.
     
  36. franfrio Miembro

    franfrio
    Joined:
    Apr 18, 2009
    Messages:
    169
    Likes Received:
    0
    Si son decímetros lo considero un valor razonable pues varia en razón de unos 9 dm Que es más o menos un metro si es así es razonable pero partir de dos metros es algo mosqueante, ponte que estas a 3 metros y baja a 2 parece un muelle. y los motores aceleran y deceleran constantemente para coregir esa oscilacion Pero entra dentro de un valor razonable. A ti que oscilación te da en ese parámetro
    En modo data display.
     
  37. danybd Miembro

    danybd
    Joined:
    Apr 26, 2010
    Messages:
    123
    Likes Received:
    0
    Pues a mi me oscila entre 5dm, por ejemplo, 4220dm --》4225dm, no se yo si esto es normal. En el aire algo sube y baja pero no es exagerado, es decir, no mantiene tan bien como con los ultrasonidos cuando esta sobre una superficie adecuada. Tampoco es que pueda comparar porque nunca he visto en directo ningun quadri - hexa - octo solo el mio :)

    Saludos.
     
  38. franfrio Miembro

    franfrio
    Joined:
    Apr 18, 2009
    Messages:
    169
    Likes Received:
    0
    Bueno aquí hay muchos multicopters pero todo el mundo menos yo vuelan con Naza o superiores controladora, con Rabbit solo yo y un amigo que está montando otro multi. Y los equipos Naza y superior son exactos no se menean del sitio y aterrizan solitas pero estamos hablando de gastarse de 360€ para arriba y de momento no puedo permitírmelo, si no tendría estos líos de momento si se mantiene y me hace retorno me conformo.
     
  39. fenestrone Nuevo Miembro

    fenestrone
    Joined:
    Feb 3, 2012
    Messages:
    96
    Likes Received:
    0
    merci por la respuesta tio, y perdon por responder tan tarde.
    la verdad que con ese precio me voy a pillar el gps a ver que tal va el tema.
    otra cosa, el gps solo actua en modo activo o tambien en pasivo? es decir: si vas equipado con gps es estrictamente necesario activar el position hold o en vuelo autoestable ya esta trabajando?
     
  40. supercanii Moderator

    supercanii
    Joined:
    Mar 12, 2008
    Messages:
    4,416
    Likes Received:
    1
    El GPS solo actúa cuando le pedís que lo haga sea en position hold o en RTH, si estas volando "normal" en estabilizado el GPS no actúa... lo mismo el sensor de presión o el sonar... actúan cuando se lo indicas...
     
  41. fenestrone Nuevo Miembro

    fenestrone
    Joined:
    Feb 3, 2012
    Messages:
    96
    Likes Received:
    0
    ups, pues vaya.
    y en el modo mantenimento de altura tampoco actua?
     
  42. supercanii Moderator

    supercanii
    Joined:
    Mar 12, 2008
    Messages:
    4,416
    Likes Received:
    1
    Para eso esta el position hold... ahí mantiene altura y posición...

    Si queres volar estabilizado y por tu cuenta es normal que no use el GPS, para eso existen modos de vuelo y formas de "configurar" que cosas queremos tener activas, no es una "pega" es normal que en determinadas circunstancias algunos elementos (sensores) actúen o no para que el modo de vuelo pueda funcionar...
     
  43. franfrio Miembro

    franfrio
    Joined:
    Apr 18, 2009
    Messages:
    169
    Likes Received:
    0
    Es normal que el canal 8 salida no actué?
    Hola creo que ya comente que me pasa lo siguiente en el canal 8 tengo la salida del gimbal horizontal y asignado un potenciómetro he comprobado que está correctamente configurado en la radio pues servo directo actúa sin problema, pero la salida de la Rabbit hace las correcciones de gimbal en dicho canal pero el potenciómetro no hace nada. ¿Esto es normal?
    En el canal 7 el potenciómetro hace las correcciones debidas. No sé si será que los tengo invertidos, no creo.
     
  44. danybd Miembro

    danybd
    Joined:
    Apr 26, 2010
    Messages:
    123
    Likes Received:
    0
    Hola Fran;

    Por fin ha parado un momento de llover!!!

    He podido realizar algunas pruebas con el bloqueo de altura y con el GPS.
    El bloqueo de altura por barómetro (>2m) me ha funcionado hoy realmente bien. Puede que le afectase algo la nueva esponja que le preparé a medida. Es un trozo bastante grande y cubre por completo el barómetro. Con esto he conseguido que me mantenga la altura bastante bien.
    En cuanto al GPS, puede que sea por la ubicación, no me ha acabado de convencer. Cuando activaba el GPS, mantenía mas o menos la posición, el único defecto es que hacia como un circulo de forma constante y realizando correcciones bastante bruscas. La segunda vez que intenté probar ya no fui capaz, se marchaba solo aparentemente para el primer sitio en donde activé el GPS como si quisiese hacer la vuelta a casa (no tengo activada esta función de momento). Estoy cargando baterías y por la tarde si el tiempo lo permite, volveré a realizar pruebas de GPS + barómetro.
    Saludos.
     
  45. franfrio Miembro

    franfrio
    Joined:
    Apr 18, 2009
    Messages:
    169
    Likes Received:
    0
    canal 7 problema

    Es normal que el canal 8 salida no actué?
    Hola creo que ya comente que me pasa lo siguiente en el canal 8 tengo la salida del gimbal horizontal y asignado un potenciómetro he comprobado que está correctamente configurado en la radio pues servo directo actúa sin problema, pero la salida de la Rabbit hace las correcciones de gimbal en dicho canal pero el potenciómetro no hace nada. ¿Esto es normal?
    En el canal 7 el potenciómetro hace las correcciones debidas. No sé si será que los tengo invertidos, no creo.
    Vale creo que es normal, nadie contesta, probé otra Rabbit y es lo mismo funciona igual, es lógico ahora que lo pienso pues
    El movimiento del gimbal horizontal para que lo quieras variar.

     
    #1945 franfrio, Jan 22, 2013
    Last edited: Feb 4, 2013
  46. fenestrone Nuevo Miembro

    fenestrone
    Joined:
    Feb 3, 2012
    Messages:
    96
    Likes Received:
    0
    hola buenas, haber si alguien puede hecharme una mano;
    me he comprado recientemente un kit de naza f450 sin la controladora, claro esta, con sus motores, sus helices de 10 pulgadas y sus respectivos reguladores.
    la cosa es que no consigo dar con un setup lo suficientemente estable como para hacer un vuelo medio decente.

    Quando no tengo nada de viento aun puedo hacer estacionarios como dios manda, pero a la que sopla lo mas minimo, la placa parece como que recula tarde y en exceso.

    la rabbit estaba instalada en otro quad y me iba de narices, pero ahora me esta sacando de mis cabales.

    si alguien que tenga un chasis como el mio volando en 3s y con la rabbit, me pasase el setup para partir de algo volable me haria un gran favor.

    muchisimas gracias de antemano
     
  47. franfrio Miembro

    franfrio
    Joined:
    Apr 18, 2009
    Messages:
    169
    Likes Received:
    0
    Le cambiaste en el software de Rabbit tools el tipo de cuadricopter casilla multiaxil mod puede que se distinto, el tuyo es la opcion 5 cuadX la distancia entre ejes, en la casilla load data, mide la distancia entre ejes de Motores y pon en dicha casilla la distancia más aproximada a tu modelo,en tu modelo es 450mm 650mm para el DJI 450 y 550 , si hiciste esos pasos bien tendría que funcionarte
    Claro vuelve a calibrar el magnetómetro y todos los parámetros.
     
  48. delapec Nuevo Miembro

    delapec
    Joined:
    Feb 2, 2009
    Messages:
    57
    Likes Received:
    0
    Hola Franfrio,
    A mi con el potenciometro me funciona perfectamente pero al intentar corregir los movimientos del chasis lo hace al reves, sabes como invertirlo? Si invierto el canal desde el software de la rabbit solo me invierte el movimiento del potenciometro pero no me invierte el movimiento de correccion.
    Por cierto, en el software a que canales tienes asignado el PTZstabilizer?
     
  49. franfrio Miembro

    franfrio
    Joined:
    Apr 18, 2009
    Messages:
    169
    Likes Received:
    0
    Es curioso, a mi no me da salida en el canal 8 del potenciómetro pero la inversión desde el software me funciona, puede ser que al tener activado el PTZstab en todas las posiciones del canal 5, vamos siempre activo, sea por eso que si esta activo esto último no deje hacer correcciones en el canal de salida de la Rabbit tengo que probarlo. Esa conclusión la he sacado por tu pregunta.
    Tienes que hacer la inversión en la segunda línea de pestañas 0_CH data. 7 y 8
    Te envió una captura.
    Captura.JPG
     
    #1949 franfrio, Feb 25, 2013
    Last edited: Feb 28, 2013
  50. delapec Nuevo Miembro

    delapec
    Joined:
    Feb 2, 2009
    Messages:
    57
    Likes Received:
    0
    Gracias por la respuesta, lo probe y funciona perfectamente. Yo solo tengo tilt por eso solo uso el canal 7 pero me funciona perfectamente, posicion la camara con el potenciometro y sigue corrigiendo perfectamente.
    Si quieres puedeo hacer una prueba conectando un servo al canal 8 y hacer la prueba?
     

Share This Page