NAZE 32, PLACA DE CONTROL A 32bit

Discussion in 'Electrónica General Multirrotor' started by abormor, Nov 7, 2012.

  1. Manueldr80 Miembro

    Manueldr80
    Joined:
    Jun 14, 2010
    Messages:
    224
    Likes Received:
    0
    Pues aqui ando mas perdido que un chivo en un garaje. He optado por pasarme al cleanflight y de momento, tem¡ngo todas las lecturas de canales correctas en el programita cuando lo conecto via USB al PC. Programo los modos de vuelo ANGLE y HORIZON, y no toco para nada ARM, que no se para que es. El caso es que los motores no arman, cosa que con el baseflight si hacian el amago...

    Por mas que bajo el gas a tope y le doy a cola a la derecha a tope, los motores no arman El led rojo y el azul estan fijos y el verde de enmedio no hace nada. Que puedo estar haciendo mal?
     
  2. odnanref Miembro

    odnanref
    Joined:
    Jun 27, 2013
    Messages:
    526
    Likes Received:
    0
    Problema al guardar

    Buenos días todos,

    Hace unas semanas tuve un accidente con el microquad y después de reconstruirlo decidí probar con variadores kiss. El problema vino cuando quise bajar el Looptime en el Cli. Cuando le doy a guardar se queda en "saving, Rebooting" y de ahí no sale. Os dejo un vídeo para que lo podáis ver mejor así como el código de colores de la naze.

    [ame]https://www.youtube.com/watch?v=0tXHrFgZW8Q[/ame]
     
  3. escurxo Miembro

    escurxo
    Joined:
    Dec 23, 2013
    Messages:
    190
    Likes Received:
    5
    Buenas chicos:

    Despues de leer,leer,leer y provar esta naze32 y sus PIDs me tienen colapsado.

    Haber si me podeis echar un cable (Clon Blackout motores Dys 2300kv):

    No consigo que la cola sea rapida(Yaw), me gira mas bien despacio.
    He provado poniendo el yaw a 10.0, el yaw rate a 1.0 ( a mas de 1 se me colapsan los motores y se queda clavado, no gira o da un salto hacia arriba), el Rc Rate a 1.75, si en la emisora en los exponenciales del gyro(yaw) le pongo -20% consigo algo de rapidez pero no la que veo en videos por ejemplo.
    Alguna sugerencia, idea??
    Gracias, Saludos.
     
  4. depakinem Miembro

    depakinem
    Joined:
    Sep 10, 2013
    Messages:
    212
    Likes Received:
    0
    Buenas compañeros,
    Necesito ayuda,resulta que me he cargado el puerto 1 de mi naze,se ha despegado el material donde se estañea el cable,total,a la porra la placa.
    Hay alguna manera de poder cambiar la salida del ppm del canal 1 a algún otro?,es el único que utilizo,que me hace falta y que me he cargado.
    Un saludo.
     
  5. Anakintf Miembro Activo

    Anakintf
    Joined:
    Oct 8, 2011
    Messages:
    1,227
    Likes Received:
    0
    Como que salida ppm? Será la entrada ppm a la naze?
    Si es la salida a motores la solución es fácil.
     
  6. depakinem Miembro

    depakinem
    Joined:
    Sep 10, 2013
    Messages:
    212
    Likes Received:
    0
    Si,eso. Jajajajajaja.
    [​IMG]


    Más vale pájaro en mano que ciento un dálmatas !!!
     
  7. Anakintf Miembro Activo

    Anakintf
    Joined:
    Oct 8, 2011
    Messages:
    1,227
    Likes Received:
    0
    Sigo sin pillarlo, la entrada PPM? Es que a mi la naze no me gusta nada de nada, prefiero la flip32, mejor distribución de componentes y conectores.
     
  8. isaacblazquez Miembro

    isaacblazquez
    Joined:
    Jun 15, 2013
    Messages:
    174
    Likes Received:
    0
    Revisa el mínimo y máximo que tienes en la placa configurado. Debería ser 1000 de mínimo 1500 medio y 2000 máximo si no usas futaba... Si la usas el medio es a 1520.

    También le daría un vistazo a los endpoints de los subtrims de los canales de la emi a ver si poniendo el min en vez de 100% a 120% te funciona.

    Saludos
     
  9. judasall Miembro Activo

    judasall
    Joined:
    Feb 12, 2009
    Messages:
    1,279
    Likes Received:
    0
    Alguien esta usando esta placa en un avion? Bueno, mas concretamente en un ala volante.
     
  10. Manueldr80 Miembro

    Manueldr80
    Joined:
    Jun 14, 2010
    Messages:
    224
    Likes Received:
    0
    Muchísimas gracias isaacblazquez. Has dado en el clavo. Ya esta el cacharrin en el aire!
     
  11. adrilh Miembro

    adrilh
    Joined:
    Nov 22, 2012
    Messages:
    539
    Likes Received:
    0
    Una solución "fácil" es rascar un poco el esmalte de la pista que sale de ese pad y soldar ahí el cable de PPM.
    No es fácil soldar en esa pista tan pequeña pero se puede hacer, también tienes que tener cuidado de rascar solo lo que es la pista, ya que si rascas lo que lo rodea es masa y al soldar es mas difícil, una vez que lo tienes soldado con cuidado de no mover mucho el cable compruebas que funciona bien y si es así ya le pones silicona caliente, epoxy o lo que mejor veas para que no se mueva el cable y se vuelva a arrancar la pista.

    Saludos.
     
  12. Turbini Nuevo Miembro

    Turbini
    Joined:
    Nov 5, 2014
    Messages:
    9
    Likes Received:
    0
    Otra solución es recompilar el firm uno mismo y cambiar el ppm al canal que quieras. En la propia documentacion de cleanflight explica como se compila. Yo lo hice y pude compilar una de prueba. Lo que no he tenido tiempo es de revisar el código para evaluar a que pin es mejor cambiarlo, porque tengo una placa igualita a la tuya que ya he raspado varias veces incluso termine soldando al componente, pero con los golpes se termina soltando y veo mejor solución recompilar el firm.

    Alguno sabe que pin es el mas desocupado, tal vez 7 u 8?

    saludos
     
  13. depakinem Miembro

    depakinem
    Joined:
    Sep 10, 2013
    Messages:
    212
    Likes Received:
    0
    Pero eso de compilar ya creo que se me escapa


    Más vale pájaro en mano que ciento un dálmatas !!!
     
  14. eslanek Gurú FPV

    eslanek
    Joined:
    Mar 3, 2011
    Messages:
    3,214
    Likes Received:
    1
    Mañana te busco a ver cual es el siguiente punto de soldadura. Hoy me pillas liado
     
  15. malarqui Nuevo Miembro

    malarqui
    Joined:
    Dec 29, 2013
    Messages:
    85
    Likes Received:
    0
  16. themithos Nuevo Miembro

    themithos
    Joined:
    Nov 13, 2014
    Messages:
    25
    Likes Received:
    0
    Buenos dias
    A ver si soy capaz de explicarme
    Tengo funcionando la AcroNaze32 en un zmr250. Con Baseflight, con el Dr4II y telemetria en la Taranis a traves del Canal 8
    Todo OK
    Pero ayer, me dio por volver a calibar los ESC ya que note uno de los motores que arranca un pelin mas tarde que el resto. Casi inapreciable, pero , yo lo noto y queria dejarlo totalmente sincronizados.

    Pues bien, iba a seguir la forma que conozco de un tutorial de Overcraft en el que se pincha en la pestaña motor del Baseflight, luego check, subo hasta arriba el deslizador Master, conectar bateria, y cuando suenan la musiquilla de los esc, bajar a tope dicho deslizador ...

    Pues bien. No llega a sonar la musica en los esc por lo que no se cuando bajar el deslizador MAster.... y lo mas curioso. intentando hacer pruebas estando la bateria conectada y subiendo dicho deslizador no me mueve los motores, tampoco con los deslizadores individuales.

    He pensado que quizas sea por tener el DR4 conectado, y lo he desconectado.
    He probado a quitar los avisos de telemetria, a resetear todo y empezar de nuevo, incluso he llegado a instalar el Cleanflight, y el resultado, el mismo
    Al final, he optado por dejarlo tal cual, pero no entiendo porque no puedo testar los motores ... al intentar hacerlo , ya os digo, el programa baseflight se queda como pillado, y nunca mueve los motores
    Si los puedo mover al armar desde la emisora ... no se, un caso raro, al menos para mi
    Por cierto, como he tenido que resetear y configurar todo de nuevo, ahora cuando estoy unos segundos con el acelerador al minimo, no se desarma solo .. antes si que lo hacia ... alguno recuerda como configurar esto? Digamos autodesarmado de motores pasados unos segundos ...

    Muchas gracias, perdonar el tocho y a ver si he sabido explicarme

    Saludos
     
  17. themithos Nuevo Miembro

    themithos
    Joined:
    Nov 13, 2014
    Messages:
    25
    Likes Received:
    0
    Bueno, solucionado...se ve que con el rx tx conectado a la naze32 no funciona.desconectado y todo correcto
    Saludos
     
  18. Simba Gurú FPV

    Simba
    Joined:
    Jul 4, 2008
    Messages:
    6,811
    Likes Received:
    13
    GPS en Baseflight

    Hola, retomo el tema del GPS y me propongo probar el funcionamiento, en un Micro Cloneout 250.

    El GPS lo reconoce y salen facilmente 7 satelites, llevo un Ublox.
    Pretendo probalo en Home (estaconario) y en RTH (vuelta a casa)

    A priori no se que parametros, se deberian modificar en el CLI, para hacer que funcione, lo que en su dia comentamos era, que para mejorar las respuestas, es aconsejable meter el modo de vuelo para RTH, con el Angle, el Baro y el Mag, por que al quedar en vuelo totalmente automatico, todas las ayudas serian pocas.

    Seria de agradecer que si alguno de vosotros tiene algo de idea de este tema, pueda faciltar, los comandos de CLI que se puedan ayudar para este tema, y yo me comprometo a postear todos los resultados que obtenga de las pruebas, de esta forma entre todos podiamos abanzar y llegar a conclusiones, a la vista y compartidas por todos.

    Un saludo.
     
  19. judasall Miembro Activo

    judasall
    Joined:
    Feb 12, 2009
    Messages:
    1,279
    Likes Received:
    0

    Yo tambien lo voy a hacer.
    Por ahora he estado provando el mag, y veia que el multi se giraba solo. Lo conecte al CLI y vi que a mas del 40% de gas el llevar los cables con consumo cerca de la placa hacia que cambiara "su norte", asi qye creo que en RTH se volvera un poco loco.
    Creo que hay que hacer un "escudo" por debajo conectado a masa para evitar estos problemas.
     
  20. rortega Gurú FPV

    rortega
    Joined:
    Apr 20, 2012
    Messages:
    5,917
    Likes Received:
    37
    Activación

    Para activarlo usa el comando feature gps

    Baud Rate

    GPS serial speed is set with the command set gps_baudrate = x where x is a speed index as follows:
    0 = 115200
    1 = 57600
    2 = 38400
    3 = 19200
    4 = 9600

    Tipo GPS

    The GPS type is set with the command set gps_type = x
    0 - NMEA
    1 - UBLOX
    2 - MTK(NMEA)
    3 - MTD(Binary)

    Todo ésto para baseflight, claro está.
     
  21. chusator Nuevo Miembro

    chusator
    Joined:
    Dec 10, 2014
    Messages:
    71
    Likes Received:
    0
    Yo uso el cleanflight y no consigo dejarlo en estacionario. Activo el baro y el mag, pero aunque active el estacionario y tenga suficientes satélites el GPS, no me hace caso. Poco a poco se va alejando.
     
  22. Simba Gurú FPV

    Simba
    Joined:
    Jul 4, 2008
    Messages:
    6,811
    Likes Received:
    13
    Vale, cada uno que aporte lo que pueda y sepa.

    Esta tarde lo he probado y el resultado es el siguiente: (cuando pueda editare el video)
    Lo he programado directamente sin necesidad de CLI.

    En un minuto me ha detectado 5 Sat, y se ha presentado en pantalla la posición GPS y demás datos.

    Con 7 Sat inicio el despegue y me alejo del Home unos 200m no recuerdo, asciendo y meto el GPSHOLD, conjuntamente con el Angle, Baro, y Mag.( esto ultimo me lo recomendó hace unos meses rortega (a que si).

    El Quad se queda clavado, literalmente no se mueve de ese punto o si lo hace es muy poco, adquiere una inclinación necesaria para contrarestar el viento que era considerable unos 30 Km/h, y la altura curiosamente tambien la controla practicamente con oscilacion de algun metro pero apreciable solo en el altimetro.

    Total, esta tarea la hace francamente bien, no se puede pedir mas es un éxito total.

    Hasta este punto todo bien, pero luego al pasar a GPSHOME, la cosa se complica, al principio muy bien se gira sobre el eje de Yaw, pero al llegar a la direccion del HOME, se pasa de largo y empieza a oscilar a un lado y a otro, y muy rapidamente se descontrola, teniendo que pasar a manual para evitar males mayores.

    Lo vuelvo a intentar en otra ocasión, con el mismo resultado, yo creo que es problema del PID de PosR y NavR, los cuales no se exactamente que son realmente, pero deduzco que son los que controlan la posición de Rol el PosR y la navegación o rumbo al Hom el NavR, pero como digo son suposiciones.
    Supongo que son estos los valores que habría que ir variando para que al navegar se fije la dirección al home con un mínimo de oscilaciones, ya que creo es la causa principal de que pierda el control.

    También noto que la flecha de indicación al Home, una vez que se descontrola ya no marca la dirección correcta, pero puede ser por lo mismo.

    Decir que luego me he dado cuenta, que no habia calibrado el Mag, y aunque creo que no es relevante, no se si afectara en algo, incluso he leído que para estas maniobras no es necesario altivar el Mag, solo es necesario el Angle y el Baro.

    De momento es todo.
     
  23. Simba Gurú FPV

    Simba
    Joined:
    Jul 4, 2008
    Messages:
    6,811
    Likes Received:
    13
    Seria interesante saber realmente que es realmente cada PID del GPS.
    En el caso de los RTH de otros controladores, de tipo avión, lo básico para que la vuelta a casa sea correcta, es ajustar la ganancia de alaveo y profundidad para que no oscile sobre esos ejes y el vuelo sea estable y sin perdida de altura.
    La cuestión es saber que parámetros son los que corresponden a los PID de rol Pits y Yaw.
     
  24. Simba Gurú FPV

    Simba
    Joined:
    Jul 4, 2008
    Messages:
    6,811
    Likes Received:
    13
    El vidreo de la prueba:

    [ame]https://youtu.be/5X5C3flgadQ[/ame]
     
  25. rortega Gurú FPV

    rortega
    Joined:
    Apr 20, 2012
    Messages:
    5,917
    Likes Received:
    37
    Cuando lo consigas poner fino pasa por aquí la configuración. Yo en su día desistí y quité el GPS en los drones donde he montado la NAZE32.

    Lo de que la flecha que indica al HOME se vuelva loca, podría deberse a interferencias en el magnetómetro. Como eso no vaya bien, cosa muy probable en un micro por ir todo tan junto, olvídate de que funcione bien el tema del GPS. Además, a día de hoy es de dominio público que los algoritmos para navegación con GPS de badeflight no son buenos, arrastran todos los problemas que padecía Multiwii, debido a que se portaron a NAZE32 tal cual y no se ha hecho mejora alguna.
     
  26. makako24 Miembro

    makako24
    Joined:
    Nov 18, 2010
    Messages:
    450
    Likes Received:
    0
    Simba has mirado que no tenga interferencias el magnetometro? A mi me pasa al reves, el GPSHOLD me hace variaciones en el lugar de algun metro pero el GPSHOME me lo hace clavado!
    Tengo entendido que si que es necesario calibrar el mag para que haga bien el gpshome , yo lo hago y me va muy bien.
    No os puedo pasar la configuracion porque he cambiado a cleanflight y de motores y palas. aun no doy con los PID correctos. Voy a ver si encuentro tiempo bueno para probar el autotune.

    Enviado desde mi GT-I9506 usando Tapatalk 2
     
  27. Simba Gurú FPV

    Simba
    Joined:
    Jul 4, 2008
    Messages:
    6,811
    Likes Received:
    13
    Hola Makako y compañia

    Ya comente que en el cleanflight me ha resultado imposible, ni tan siquiera me reconoce el GPS, por eso me he vuelto al Baseflight en el que lo reconoce a la prmera.
    Pasa cuando puedas la configuración del Cleanfliht para GPS tanto a instalacion del GPS, como los parametros de PID que utilizas.

    Si tal cmo dices el GPSHOME te funciona correctamente, y el GPShold no te funciona bien, por el supuesto desajuste o interferencias, creo que estamos por el buen camino.
    Tan solo tenemos que hacer coincidir tu sistema el mio, a mi como ves en el video el Home lo claba perfecto, y no tengo ajustado el Mag, es decir que ni lo he calibrado, esta tal como queda despues del flaseo de la FC.

    Por lo tanto esto me dice que para el Home, el Mag no hace nada, y en cambio a ti en el RTH te va bien con las supuestas interferencias.

    Pues hay algo que se nos escapa, y seria muy interesante que comparemos configuraciones.

    Yo en cuanto pueda voy a calirar el mag y a volver a probar en vuelo, pero me gustaria cambiar o copiar tus PID en otro perfil para probar mas cosas.

    Un saludo.
     
  28. makako24 Miembro

    makako24
    Joined:
    Nov 18, 2010
    Messages:
    450
    Likes Received:
    0
    Pues a mi tampoco me funcionaba al principio el gps con el cleanflight pero es por no tener bien configurado los puertos fijate que si no lo configuras bien, no te deja configurar los baudios ni el protocolo, vamos que te deja cambiarlo pero cuando le das a save, se pone otra vez por defecto!
    El tema es que por cambio de motores y palas, no me va bien ahora el bichillo! Jeje
    Estoy de mudanza y no tengo tiempo para volar.
    Te paso la configuracion anterior en baseflight que iba bien asi.(la tengo en el portatil, cuando pueda te la subo.)
     
  29. Simba Gurú FPV

    Simba
    Joined:
    Jul 4, 2008
    Messages:
    6,811
    Likes Received:
    13
    OK, espero tus datos.
    Bueno al lio, he vuelto a probar esta mañana, ya funciona el RTH :laugh:.
    Los cambios respecto al otro dia han sido, calibrar el Mag (creo que al final esto era importante), y cambiar algunos parametros por hacer algo.
    Realmente como makako comento que con el Cleanfight le funcionba, he revisado los valores por defecto del Cleanflight y del Baseflight y he visto que algunos estaban cambiados y he metido en el base los del Clean.

    El resultado ha sido muy bueno, la lastima es que me deje en casa la SD del grabador y no he podido grabar el video.

    El dia era ventoso y a 100m mas, el Home le costaba clabarlo, seguramente por los parametros que cambie, pero el RTH lo hace perfecto, lento pero perfecto velocidad de 12 Km/h (igual se puede cambiar algo para ir mas rapido), se gira sobre el Yaw y al apuntar al Home se para e inicia el regreso en linea recta, la altura la mantiene con muy poco error +- 1m, y al llegar a la vertical del Home, se gira sobre Yaw 180º y se queda en esa posicion sin perter altura, totalmente inmovil.

    Lo he probado 2 veces y repetición de la jugada todo perfecto.

    Solo por decir algo al entrar en Hold y con el aire y mis cambios de PID lo hace lento y le cuesta cojer la inclinación para contrarestar el viento, pero una vez conseguido lo mantiene Bien.

    Creo que solo falta pulir un poco los PID, pero como no tengo las ideas claras de lo que es cada cosa, resulta dificil acertar a prueba y error.

    Chicos probar que funciona a ver si entre todos lo pulimos.

    Un saludo.

    P.D. cuando pueda hare un video.
     
  30. makako24 Miembro

    makako24
    Joined:
    Nov 18, 2010
    Messages:
    450
    Likes Received:
    0
    Bien symba me alegro que te funcione bien !
    A mi tambien me hacia el RTH a 12 Km/h busque como configurar eso para hacerlo mas rapido pero no encontre nada.

    Enviado desde mi GT-I9506 usando Tapatalk 2
     
  31. Simba Gurú FPV

    Simba
    Joined:
    Jul 4, 2008
    Messages:
    6,811
    Likes Received:
    13
    Los parámetros que tienes metidos, son los que viene por defecto en el Cleanflight ???

    Yo por mi parte voy a meter esos parámetros en un perfil y en otro los del Baseflight por defecto y comparare resultados, pero a priori y con los resultados de esta mañana, creo que los del Baseflight funciona mejor, mas rápido en posicionarse en Hold.

    Lo de la velocidad de regreso yo tampoco he encontrado nada, como no sea esto del CLI:
    Variable
    Min Max Default
    nav_speed_min 10 2000 100
    nav_speed_max 10 2000 300
    nav_slew_rate 0 100 30
     
  32. eslanek Gurú FPV

    eslanek
    Joined:
    Mar 3, 2011
    Messages:
    3,214
    Likes Received:
    1
    Si que se puede aumentar la velocidad de vuelta, pero indirectamente, por ejemplo cambiando la inclinación máxima de pitch, mientras mas se incline más rápido ira, ya que si solo diera gas, sin inclinarse más, subiría.
     
  33. Simba Gurú FPV

    Simba
    Joined:
    Jul 4, 2008
    Messages:
    6,811
    Likes Received:
    13
    Ultima y definitiva prueba, todo parece ir bien y se puede decir que es totalmente operativo.
    Hay que tener en cuenta, la fuerte frenada que hace si vas a velocidad.
    Lo primero que intenta es clavar el punto de accionamiento del Hold, para lo cual tiene que frenar muy brusco y parece que valla a perder el control por la inclinación, y en la frenada puede llegar a ganar bastante altura, luego la va bajando.
    En RTH si tiene viento en cola, lo que hace es frenar y tratar de mantener +- 12 Km/h.

    Pongo video y captura de configuración:

    [ame]https://youtu.be/ZCZoWubwyFc[/ame]
     

    Attached Files:

    #583 Simba, Jun 1, 2015
    Last edited: Jun 1, 2015
  34. makako24 Miembro

    makako24
    Joined:
    Nov 18, 2010
    Messages:
    450
    Likes Received:
    0
    simba te pongo mi antiguaconfiguracionel basflight como te dije:
     

    Attached Files:

    • aux1.png
      aux1.png
      File size:
      177.1 KB
      Views:
      167
    • gps.jpg
      gps.jpg
      File size:
      147.4 KB
      Views:
      143
    • modes.png
      modes.png
      File size:
      169.3 KB
      Views:
      142
    • PID.png
      PID.png
      File size:
      173.6 KB
      Views:
      166
    #584 makako24, Jun 1, 2015
    Last edited: Jun 1, 2015
  35. Simba Gurú FPV

    Simba
    Joined:
    Jul 4, 2008
    Messages:
    6,811
    Likes Received:
    13
    Pues makako, llevamos la misma configuración, es decir la que trae por defecto el Baseflight.
    No se como ves el comportamiento en el video, yo lo veo totalmente operativo.
    No entiendo, el por que tanta gente dice que está por desarrollar, si realmente es operativo.
    Por lo que yo he visto, lo único que hay que hacer, es configurar bien la calibración del Magnetometro, que al final resulta que es totalmente imprescindible.

    Aunque no sale en el video, hice mas pruebas a cierta velocidad unos 60Km/h, activando directamente el RTH sin pasar por HOLD, y aunque el frenazo lo hace, parece hacerlo menos mientras gira hacia el Hom, y en la frenada sube bastante, por que busca la dichosa velocidad de 11 Km/h.
    Si no tuviera puesto esa velocidad el funcionamiento seria mucho mas fluido y no tardaría tanto en volver al Hom, que se hace eterno.

    Cuando puedas pasas la configuración completa del GPS en Cleanflaight, que es lo que me queda pendiente.
     
  36. Simba Gurú FPV

    Simba
    Joined:
    Jul 4, 2008
    Messages:
    6,811
    Likes Received:
    13
    eslanek, no es que se inclene poco, es que busca para mantener el valor de unos 11 o 12 Km/h, incluso con viento en cola, lo que hace es inclinarse al contrario para frenar el avance, u mantener la velocidad.

    Debe de ser algún parametro del CLI, o si no esta preparado para que salga en CLI, lo tendrá en linea de programación, pero estoy seguro que hay algo, que los que sabéis de programación lo podríais dejar para que se pueda configurar a voluntad, dentro de unos valores, los cuales si se sobrepasan, el control se haría dificultoso o no podria.
    Si tan solo se pudiera ajustar hasta unos 20Km/h, seria mucho mas practico, ya que en caso de necesitar un RTH por Failsafe, si estas un poco alejado, no vuelve por que se queda sin baterias.
     
  37. chusator Nuevo Miembro

    chusator
    Joined:
    Dec 10, 2014
    Messages:
    71
    Likes Received:
    0
    Hola!
    Esta semana he probado el RTH en la naze32 y va MUY bien.
    Con BARO y MAG activado. Le cuesta mas o menos en función del parametro "max_angle_inclination". De momento como no corro, lo tengo limitado a 15º (Si, es poco, pero estoy aprendiendo).
    Con rachas de 25 Km/h, volvió muy decentemente, despacito y en línea recta.
    Con la limitación en 30º viene con bastante brio.

    Viene a la misma altura en la que hayamos activado el RTH y cuando llegua encima nuestro, se queda esperando, no hace landing.
    Si quereis, esta semana grabo vídeo y lo subo.

    Un saludo
     
  38. Jonylito Nuevo Miembro

    Jonylito
    Joined:
    Apr 3, 2015
    Messages:
    29
    Likes Received:
    0
    Pues suelen decir que no funciona muy bien con gps y tal... Si funciona bien, es una muy buena opción.
     
  39. Simba Gurú FPV

    Simba
    Joined:
    Jul 4, 2008
    Messages:
    6,811
    Likes Received:
    13
    Pues si, si que funciona y ademas bastante bien.
    Gracias chusator por el aporte de "max_angle_inclination", a mi tambien me funciona como comentas, lento pero seguro, cuando pueda probare lo del "max_angle_inclination".

    Hay que tener en cuenta una cosa importante, hay que calibrar bien el Mag, tal como se comenta en las instrucciones volteandola en los 3 ejes, si esto no se hace bien o no actibamos el mag, junto con el RTH, no funciona ya que necesita la brujula magnetica para reconocer el angulo de rumbo a la base.

    Un saludo.
     
  40. Simba Gurú FPV

    Simba
    Joined:
    Jul 4, 2008
    Messages:
    6,811
    Likes Received:
    13
    Y otra cosa importante, tambien hay que meter Baro para que mantenga la altura de RTH.
     
  41. rortega Gurú FPV

    rortega
    Joined:
    Apr 20, 2012
    Messages:
    5,917
    Likes Received:
    37
    No es que no funcione bien, funcionar funciona, yo al menos nunca he dicho eso. El RTH de Miltiwii/Naze32 siempre ha funcionado. Sin hembargo, teniendo en cuenta que corremos software en un procesador muy potente, las funciones de GPS dejan mucho que desear por su imprecisión, comparado al comportamiento de dichas funciones en otras plataformas. Cuando decides usar el GPS HOLD para tomar secuencias de vídeo estáticas, y lo comparas con los resultados de otros compañeros que usan otras plataformas, empiezas a plantearte el pasar a esas otras. Portar el firm de Multiwii a Naze32 no supuso ningún avance en ese sentido, y se quedó estancado.

    Los que éramos acérrimos a Multiwii, estábamos acostumbrados a volar en modo ACRO y no nos asustaba ir volando a toda pastilla y pulsar el switch de la emisora para activar el modo GPS HOLD. Era, y es, de auténtico infarto, sobre todo volando en FPV. El RTH como opción para tener cierta tranquilidad en el caso de un failsafe es más que suficiente, pero no le pidas nada más a la plataforma.

    Los que si estaban haciendo ciertos avances en las funciones de GPS para Naze32, eran los que desarrollaban Harakiri, que un fork/branch que surge también a partir de baseflight. Se conseguía mayor precisión y mejoras en las funciones de GPS Hold, pero creo que su desarrollo también se paró, y era un completo parcheo por alguien que no dominaba el tema del desarrollo para procesadores ARM, con todo lo que ello implicaba.

    Lo que proponéis de que los que sabemos desarrollar mejoremos algo está muy bien, pero no es algo tan fácil ni tan simple. Si así fuera, en el tiempo que lleva baseflight en funcionamiento, o los de cleanflight, ya le habrían metido mano. Yo tengo sobre la mesa de mi salón uno de los varios manuales de la arquitectura ARMv7 que hay que empollarse para hacer las cosas bien, y da vértigo (más de400 páginas), aún siendo alguien que tiene experiencia en desarrollo en C y ensamblador para arquitectura x86.

    Todo ésto que estáis haciendo está muy bien, pero muy probablemente váis a llegar a la misma conclusión a la que llegamos la mayoría que empezamos en su día con Multiwii, y que no creíamos nada de lo que decían los que antes que nosotros habían pasado por lo mismo: si quieres que tu quad con Multiwii/Naze32 se comporte como la NAZA, ponle una NAZA.

    Aún así no os desaniméis, porque mientras estáis investigando y probando, estáis aprendiendo un huevo sobre estas tecnologías.
     
  42. Simba Gurú FPV

    Simba
    Joined:
    Jul 4, 2008
    Messages:
    6,811
    Likes Received:
    13
    rortega, estoy al 100% con todo o que comentas :laugh:, pero no podía quedarme sin probarlo, y por eso lo probé y ahora pienso lo mismo que tu, pero como bien dices esto hay que probarlo, no lo mejoraremos por que no sabemos hacerlo, pero yo me quedo muy satisfecho de mis pruebas, y ya se cuales son sus limitaciones.

    Yo ya le he quitado el GPS a mi Cloneout 250, pero que me quiten lo bailao :-800:.

    Gracias
     
  43. rortega Gurú FPV

    rortega
    Joined:
    Apr 20, 2012
    Messages:
    5,917
    Likes Received:
    37
    +1
     
  44. odnanref Miembro

    odnanref
    Joined:
    Jun 27, 2013
    Messages:
    526
    Likes Received:
    0
    Configuración Naze 32 desde 0. Vídeo 1/3

    Aprovechando que he recibido una nueva Naze32 he decidido grabar 3 vídeos sobre como configurar la Naze32 desde 0. Con Telemetría, modos de vuelo y todo aquello que me parezca relevante y básico a la hora de montar esta controladora.

    [ame]https://www.youtube.com/watch?v=LcPNTvS67i4[/ame]
     
  45. ardufriki Miembro

    ardufriki
    Joined:
    Mar 12, 2014
    Messages:
    651
    Likes Received:
    2
    Hola, me ha pasado que de repente mi naze32 está frita. Aquí lo explico. ¿os ha pasado? (supongo que arreglo no tiene).
     
  46. AlexT Miembro

    AlexT
    Joined:
    Nov 23, 2014
    Messages:
    180
    Likes Received:
    0
    Afrofly32 no conecta al Clean

    Hola, a ver si me podéis echar un cable.
    Una Afrofly32 que funcionaba perfectamente de repente se quedo como colgada, y no conecta al clean.
    Entro en modo Boot, cargo la version de la naze correspondiente, la barra verde se llena y me dice que todo OK, desactivo las casillas del boot, intento conectar y no hay manera.
    Hay alguna forma de resetearla y dejarla de fabrica?
     
  47. rortega Gurú FPV

    rortega
    Joined:
    Apr 20, 2012
    Messages:
    5,917
    Likes Received:
    37
    Hay una forma de hacer una especie de reset, que lo que hace es activar el bootloader, se usa para aquellas ocasiones en las que ha habido un fallo durante la carga del firm, o incluso en situaciones como la que describes.

    En la cara superior, a la izda de los pines de los motores, hay dos pads serigrafiados con la palabra Boot. En la figura 1 del manual te lo señalan con un 9.

    Los tienes que puentear y a continuación meterle alimentación. Después de eso ya está en modo boot para poder subir el firm.

    Lo tuve que usar en varias ocasiones, aunque en aquella época no existían ni el baseflight-configurator, y por supuesto ni el cleanflight. Solía usar la misma aplicación que se indica en el manual para subir el archivo hex. Imagino que desde el badeflight-configurator también se podrá.
     
  48. AlexT Miembro

    AlexT
    Joined:
    Nov 23, 2014
    Messages:
    180
    Likes Received:
    0
    Gracias Rortega, si ese es el modo boot que comento, me deja cargar el .hex pero a la hora de conectar normalmente con el clean no hay manera, bueno si, anoche después de mil intentos consigue entrar, pero al poco de configurarla se bloqueo y ya no lo conseguí mas.
    ¿me recomendáis algún archivo hex en especial para que me la deje de fabrica?
     
  49. rortega Gurú FPV

    rortega
    Joined:
    Apr 20, 2012
    Messages:
    5,917
    Likes Received:
    37
    No quedaba del todo claro en tu post el procedimiento, pero el hex cómo lo subes, desde el software recomendado en el manual?

    No se me ocurren grandes cosas, una podría ser subir algún firm programado exclusivamente para borrar la flash, como se suele hacer en arduino cuando se comporta de forma "extraña" una controladora. Ésto no lo he hecho nunca con naze32. Podría ser que se haya "corrompido" la información de los parámetros de configuración.

    Pero antes intenta ver si usando un módulo ftdi o un Bluetooth puedes comunicarte con la naze desde el configurator o alguna app android, en tal caso podrías entrar en modo CLI y configurar la naze32 para que redirija las comunicaciones al puerto deseado, no siendo necesario lo anterior.

    Otra podría ser modificar los valores por defecto del código fuente para usar otro puerto distinto como puerto de comunicaciones, compilar y subir, pensando en que el problema estuviese en la uart1 (cosa que no tendría mucho sentido si ya te deja subir el firm).

    Prueba si una ve
     
  50. AlexT Miembro

    AlexT
    Joined:
    Nov 23, 2014
    Messages:
    180
    Likes Received:
    0
    si desde el soft que recomienda en el pdf, y también directamente desde el clean activando las correspondientes casillas.
    En ambos casos carga sin problema lo que le ponga, pero sigue sin conectar.
    después subo un video de la combinación de luces que hace, a ver si alguien sabe lo que nos quiere decir.......
     

Share This Page