Herramientas Buscar en Tema
Antiguo 16/11/2009, 19:19   #1
JuanTrillo
* * * * * *
 
Avatar de JuanTrillo
 
Ingreso: 21/sep/2007
Ubicación: Bormujos (Sevilla)
Mensajes: 4.951
Primer post Destacado
Editado por JuanTrillo; 12/02/2016 a las 13:40

Ikarus OSD

Version 297.001 87.051 72.003

Consola: 297.001
Firmware 223: 087.051
Firmware uplink: 072.003

<descargar>




Drivers USB. <descargar>

Manual. <descargar>

Tutorial General detallado<descargar>

Guia de Conexionado detallado<descargar>

Guia de Ventanas de configuracion<descargar>

Guia de Ventana de vuelo<descargar>

Webs:
http://www.ikarus-osd.com
http://www.dsrobotics.com

Tutorial Gps Flytron (Juande)<link>
GPS Isolator:http://www.aeromodelismovirtual.com/...=26549"]<link>
Tipografía MINI<descargar>

Programador para desarrolladores.
http://dx.com/p/usb-debug-adapter-fo...1#.UuLRxIq0o94
Adaptador de programador:
<link>
Fuentes Ikarus completos:
https://code.google.com/p/ikarus-osd/



Ejemplo de perfecto RTH con Ikarus.(by Juanvivo)
mascota_articulosImágenes
Hacer clic en la imagen para la versión completa

Nombre:  productos ikarus.jpg
Vistas: 1608
Tamaño:  174,9 KB (Kilobytes)
ID: 37848   Hacer clic en la imagen para la versión completa

Nombre:  1.jpg
Vistas: 332
Tamaño:  153,6 KB (Kilobytes)
ID: 61090  
JuanTrillo esta en línea ahora   Responder Citando
Antiguo 03/06/2012, 21:59   #3211
JuanTrillo
* * * * * *
 
Avatar de JuanTrillo
 
Ingreso 21/sep/2007
De Bormujos (Sevilla)
4.951 Mensajes
Cita:
Iniciado por waverider Ver mensaje
...

me sigue pasando que el recorrido del stick del gas se desajusta y he observado que si enchufo la bateria del motor al final no me pasa.

lo del gps lo solucione poniendo un bec al gps. En cuanto a los PID aun tengo que ajustarlos un poco, pero funcionar funciona.

tengo dudas de como ajustar voltimetros y amperimetros, sigo sin tenerlo claro a pesar de tus explicaciones.
Dame un MP con una dia y hora de esta semana y hablamos via telefono/gtalk/skype o a grito pelao

JuanTrillo
JuanTrillo esta en línea ahora   Responder Citando
Antiguo 04/06/2012, 13:21   #3212
rgon
*
 
Ingreso 24/mar/2011
De Lisboa
34 Mensajes
Enviar un mensaje por Skype™ a rgon
Futaba 10CG Mezcla 223

Hola,

Creo que puede ser útil. Gracias al autor.


http://www.youtube.com/watch?v=fYqXF...&feature=g-u-u
rgon está desconectado   Responder Citando
Antiguo 04/06/2012, 14:10   #3213
waverider
* * * * * *
 
Avatar de waverider
 
Ingreso 13/feb/2011
De AEROPLEX.ES
3.178 Mensajes
Cita:
Iniciado por JuanTrillo Ver mensaje
Dame un MP con una dia y hora de esta semana y hablamos via telefono/gtalk/skype o a grito pelao

JuanTrillo
:) jeje, Ok. en cuanto repare el modelo te aviso para que me ayudes con estos ajustes!
waverider esta en línea ahora   Responder Citando
Antiguo 04/06/2012, 15:10   #3214
abogado
*
 
Ingreso 04/jun/2012
5 Mensajes
estoy perdido con ikarus

hola me llamo juan y no se si escribo en el sitio correcto para que me ayuden con un ikarus osd ,gracias a hilos de este foro he solucionado muchos problemas yo soy nuevo en el mundo del fpv y mas con ikarus osd yo suelo volar todo jets electricos,os agradecería que me ayudarais por que tengo problemas con ikarus osd he volado con el solo con lo basico y con interruptor de3 posiciones resulta que se me rompió el osd lo envié a reparar y ahora lo e montado otra vez y lo he actualizado al ultimo firmware cuando lo pongo en marcha me sale de vez en cuando la pantalla de configuracion principal pero otras veces me sale directo a la telemetría y no puedo hacer nada ,no se si me he explicado gracias por ayudarme un saludo.
abogado está desconectado   Responder Citando
Antiguo 04/06/2012, 16:59   #3215
JLT_GTI
* * *
 
Avatar de JLT_GTI
 
Ingreso 04/dic/2011
465 Mensajes
Cita:
Iniciado por JuanTrillo Ver mensaje
Es mucho mas rapido si colocas un jumper entre los pines 2 y 3 (rojo y verde) de la bateria de video. El pin derde de la bateria de video esta comunicado con el pin rojo de la bateria de motor. ¿Para que? Pues si ahora conectas la salida de tu amperimetro (negro,rojo,verde) a su conector de ikarus estaras alimentando ambas entradas (batmotor+batvedeo) con la bateria de motor.

Pones una bateria 3S y su voltaje lo pones en la casilla Read1(Vvideo) y la casilla Read1(Vmotor). Pulsas leer junto a ambos datos. Cambias la bateria a 2S y repites el proceso en la casilla Read2(Vvideo) y la casilla Read2(Vmotor). Pulsas leer junto a ambos datos. En el proceso de cambio de bateria ikarus se apagara-reiniciará y situara en modo USB de nuevo, pero los datos de la consola de la medicion anterior no se habran perdido.

A vale.. ya entiendo mejor.. a ver si lo he pillado:

conectamos una sola bateria al motor y configuramos ikarus para que funcione desde la bateria de motor y con una bateria (3S) ponemos un voltaje a los dos VVideo1 y Vmotor1 y luego la desenchufamos, ponemos la otra (2S) y repetimos y asi tenemos calibrados ambos sensores en el mismo paso no?

Lo que no veo claro es lo de los jumpers.. donde se ponen? Puedo usar algun jumper del ikarus? tengo que buscar pero no se si tendre yo jumpers por aqui...

Por cierto.. como se puede saber si me entrara el failsafe? porque algo lei de si entra a 2000us y mis canales van mas alla de 2000us ...
El de control no porque con mezcla 3 basico no pasa de 1800 o 1200us ..el de motor tendria que mirar pero ....

Para evitar sustos porque si "malconfiguro" un RTH sin estabilizador a lo cutre para ver como se porta el Escuela sin estabilizador pero sin contar con el .. pero me entra el failsafe asi de sopeton aun cerca se puede liar parda...
JLT_GTI está desconectado   Responder Citando
Antiguo 04/06/2012, 17:13   #3216
apanyz
* * * *
 
Avatar de apanyz
 
Ingreso 06/oct/2010
De Martos (Jaen)
911 Mensajes
Cita:
Iniciado por abogado Ver mensaje
hola me llamo juan y no se si escribo en el sitio correcto para que me ayuden con un ikarus osd ,gracias a hilos de este foro he solucionado muchos problemas yo soy nuevo en el mundo del fpv y mas con ikarus osd yo suelo volar todo jets electricos,os agradecería que me ayudarais por que tengo problemas con ikarus osd he volado con el solo con lo basico y con interruptor de3 posiciones resulta que se me rompió el osd lo envié a reparar y ahora lo e montado otra vez y lo he actualizado al ultimo firmware cuando lo pongo en marcha me sale de vez en cuando la pantalla de configuracion principal pero otras veces me sale directo a la telemetría y no puedo hacer nada ,no se si me he explicado gracias por ayudarme un saludo.
eso te pasa porque estas alimentando el Ikarus por le entrada del sensor y psa directamente a la pantalla de vuelo.

Alimenta el ikarus solamente por la entrada normal y veras como no te pasa.
apanyz esta en línea ahora   Responder Citando
Antiguo 04/06/2012, 17:31   #3217
JuanTrillo
* * * * * *
 
Avatar de JuanTrillo
 
Ingreso 21/sep/2007
De Bormujos (Sevilla)
4.951 Mensajes
Cita:
Iniciado por JLT_GTI Ver mensaje
A vale.. ya entiendo mejor.. a ver si lo he pillado:
conectamos una sola bateria al motor y configuramos ikarus para que funcione desde la bateria de motor y con una bateria (3S) ponemos un voltaje a los dos VVideo1 y Vmotor1 y luego la desenchufamos, ponemos la otra (2S) y repetimos y asi tenemos calibrados ambos sensores en el mismo paso no?
Correcto.

Cita:
Iniciado por JLT_GTI Ver mensaje
Lo que no veo claro es lo de los jumpers.. donde se ponen? Puedo usar algun jumper del ikarus? tengo que buscar pero no se si tendre yo jumpers por aqui...
Pillate el jumper de la camara2, el superior y lo usas para conectar pines rojo y verde de la bateria de video. Luego, cuando termines de calibrar vuelves a ponerlo en su sitio.

Cita:
Iniciado por JLT_GTI Ver mensaje
Por cierto.. como se puede saber si me entrara el failsafe? porque algo lei de si entra a 2000us y mis canales van mas alla de 2000us ...
El de control no porque con mezcla 3 basico no pasa de 1800 o 1200us ..el de motor tendria que mirar pero ....
El failsafe lo haces de la siguiente forma:

(1) Sube trim de motor al maximo.

(2) Para indicar al regulador que esa será la posicion nueva de motor off haz lo siguiente:
(2)(1) sube stick de motor
(2)(2) conecta bat motor
(2)(3) espera un pitido y baja el stick.

(3) Ahora haz el asistente de recorrido de servos de nuevo.
¿Que hemos hecho? Pues hemos subido el valor minimo de motor. Ahora podemos fijar FS en nuestro receptor (si es DL pulsando el boton) en la posicion de trim abajo del todo. Una vez hecho esto vuelve a ponerlo a su posicion de vuelo, que es arriba.
¿Cómo comprobarlo? Facil. Pon ikarus en modo una sola bateria (recuerda, lo del jumper de antes) e ikarus entrará en la ventana de vuelo directamente. Cuando apagues emisora veras tras unos segundos (esto es ajustable) que entra la ventana FS y tu avion hará RTH (salvo que estes en ruta y le hayas fijado que en caso de FS siga la ruta)

Cita:
Iniciado por JLT_GTI Ver mensaje
Para evitar sustos porque si "malconfiguro" un RTH sin estabilizador a lo cutre para ver como se porta el Escuela sin estabilizador pero sin contar con el .. pero me entra el failsafe asi de sopeton aun cerca se puede liar parda...
Veamos. Solo habra RTH si:
(1) Ikarus detecta motor por debajo del valor minimo (lo de antes)
(2) se sale el conector del cable ppm+rssi
(3) se lo ordenas tu.

Verifica estas tres posibilidades antes de volar.


JuanTrillo
JuanTrillo esta en línea ahora   Responder Citando
Antiguo 04/06/2012, 17:39   #3218
JuanTrillo
* * * * * *
 
Avatar de JuanTrillo
 
Ingreso 21/sep/2007
De Bormujos (Sevilla)
4.951 Mensajes
Cita:
Iniciado por abogado Ver mensaje
hola me llamo juan y no se si escribo en el sitio correcto para que me ayuden con un ikarus osd ,gracias a hilos de este foro he solucionado muchos problemas yo soy nuevo en el mundo del fpv y mas con ikarus osd yo suelo volar todo jets electricos,os agradecería que me ayudarais por que tengo problemas con ikarus osd he volado con el solo con lo basico y con interruptor de3 posiciones resulta que se me rompió el osd lo envié a reparar y ahora lo e montado otra vez y lo he actualizado al ultimo firmware cuando lo pongo en marcha me sale de vez en cuando la pantalla de configuracion principal pero otras veces me sale directo a la telemetría y no puedo hacer nada ,no se si me he explicado gracias por ayudarme un saludo.
Te explico las formas de arrancar ikarus

MODO FRIO: Metes bateria de video y esperas unos segundos. Entramos en el menu principal. Ahora metes bateria de motor y tras pillar satelites le das a READY TO FLY. Ya estas en la ventana de vuelo.

MODO CALIENTE: Metes primero batería de motor (la salida del amperimetro con conector futaba) y despues batería de video. Ikarus por seguridad entra en vuelo porque piensa que ha podido haber un malcontacto en la entrada de video.

Si tienes la ultima version, pasas de la ventana de vuelo al menu con un atajo. Manten

MOTOR ABAJO + DIRECCION IZQUIERDA
ELEVADOR ABAJO+ALERON DERECHA

Tras una cuenta atras que aparecerá en pantalla si usas el instrumento BADRX vuelves al menu principal. Util para recalibrar estabilizador o fijar casa con mas precision entre otras opciones.

JuanTrillo
JuanTrillo esta en línea ahora   Responder Citando
Antiguo 04/06/2012, 20:31   #3219
JuanTrillo
* * * * * *
 
Avatar de JuanTrillo
 
Ingreso 21/sep/2007
De Bormujos (Sevilla)
4.951 Mensajes
Error en asistentes detectado.

Os pongo un video donde se observa que tras hacer la calibracion de los voltimetros se corrompen los ajuste de RSSI y ajustes del amperimetro.

Mientras tanto haced los ajustes en este orden:

voltimetros
rssi
amperimetro.

Os dejo el video




JuanTrillo
JuanTrillo esta en línea ahora   Responder Citando
Antiguo 04/06/2012, 23:52   #3220
abogado
*
 
Ingreso 04/jun/2012
5 Mensajes
Muchisimas gracias por vuestra ayuda ya he conseguido que me funcione bien.la verdad es que es un poco complicado para mi muchas muchas gracias .otra pregunta yo utilizo una emisora spektrum dx7 como puedo conectar la entrada Rssi? también antes apagaba la emisora y me salia en la pantalla failsafe y ahora no ,esto es debido a el firmware ?si es asi que firmware puedo poner para que sea mas sencillo su uso ? lo siento por mi inexperiencia pero antes de preguntar he leido y no me que da nada claro saludos.

Editado por abogado; 05/06/2012 a las 00:07
abogado está desconectado   Responder Citando
Antiguo 05/06/2012, 09:49   #3221
JuanTrillo
* * * * * *
 
Avatar de JuanTrillo
 
Ingreso 21/sep/2007
De Bormujos (Sevilla)
4.951 Mensajes
Cita:
Iniciado por abogado Ver mensaje
Muchisimas gracias por vuestra ayuda ya he conseguido que me funcione bien.la verdad es que es un poco complicado para mi muchas muchas gracias .otra pregunta yo utilizo una emisora spektrum dx7 como puedo conectar la entrada Rssi? también antes apagaba la emisora y me salia en la pantalla failsafe y ahora no ,esto es debido a el firmware ?si es asi que firmware puedo poner para que sea mas sencillo su uso ? lo siento por mi inexperiencia pero antes de preguntar he leido y no me que da nada claro saludos.
Mirate el post 3218 donde explico las formas de ajustar FS. Se trata de programar FS en motor por debajo del valor minimo de recorrido de motor definido en los asistentes de recorridos de servos. Si ikarus tiene que motor va entre 1000us y 2000us y lee 900 entenderá que es una situacion de FS y meterá el autopiloto.

JuanTrillo
JuanTrillo esta en línea ahora   Responder Citando
Antiguo 05/06/2012, 12:43   #3222
rgon
*
 
Ingreso 24/mar/2011
De Lisboa
34 Mensajes
Enviar un mensaje por Skype™ a rgon
MWC con FY_2_IR

Hola,

¿Alguien ha probado el MWC con el cable FY_2_IR?

Puedo obtener una lectura razonable, pero cada vez que encienda la batería tiene que calibrar el IR.
rgon está desconectado   Responder Citando
Antiguo 05/06/2012, 17:58   #3223
JLT_GTI
* * *
 
Avatar de JLT_GTI
 
Ingreso 04/dic/2011
465 Mensajes
Bueno... logre calibrar las lecturas de los voltimetros usando la consola que me pasasteis y el sistema de Juan.. me quedaria calibrar el amperimetro .. Ah y la consola esa ya se pone en verde

supongo que para ese basta con fijar una lectura de 10 y 20A por ejemplo no? (es decir que no hace falta ir al consumo maximo)

Tambien fije la lectura RSSI (aunque por lo que veo creo que tendre que recalibrarla despues de calibrar el amperimetro pero es un segundo) y funciona..

Lo que no me esta funcionando es el GPS pero cierto es que deberia probarlo mejor al aire libre en vez de por la ventana .. y que donde lo tengo (el avion) ahora el movil tampoco pilla satelites.. pero sacando el movil a la ventana empieza a pillar satelites rapido ...


Volviendo al tema de Failsafe.. mire los recorridos que tiene calibrado ahora y el acelerador me dice que va desde 1100 a 1940 ... con esas lecturas no deberia tener FS no?
JLT_GTI está desconectado   Responder Citando
Antiguo 05/06/2012, 19:28   #3224
JuanTrillo
* * * * * *
 
Avatar de JuanTrillo
 
Ingreso 21/sep/2007
De Bormujos (Sevilla)
4.951 Mensajes
Cita:
Iniciado por rgon Ver mensaje
Hola,

¿Alguien ha probado el MWC con el cable FY_2_IR?

Puedo obtener una lectura razonable, pero cada vez que encienda la batería tiene que calibrar el IR.
¿Que es el MWC?

JT
JuanTrillo esta en línea ahora   Responder Citando
Antiguo 05/06/2012, 19:32   #3225
JuanTrillo
* * * * * *
 
Avatar de JuanTrillo
 
Ingreso 21/sep/2007
De Bormujos (Sevilla)
4.951 Mensajes
Cita:
Iniciado por JLT_GTI Ver mensaje
Bueno... logre calibrar las lecturas de los voltimetros usando la consola que me pasasteis y el sistema de Juan.. me quedaria calibrar el amperimetro .. Ah y la consola esa ya se pone en verde

supongo que para ese basta con fijar una lectura de 10 y 20A por ejemplo no? (es decir que no hace falta ir al consumo maximo)

Tambien fije la lectura RSSI (aunque por lo que veo creo que tendre que recalibrarla despues de calibrar el amperimetro pero es un segundo) y funciona..

Lo que no me esta funcionando es el GPS pero cierto es que deberia probarlo mejor al aire libre en vez de por la ventana .. y que donde lo tengo (el avion) ahora el movil tampoco pilla satelites.. pero sacando el movil a la ventana empieza a pillar satelites rapido ...


Volviendo al tema de Failsafe.. mire los recorridos que tiene calibrado ahora y el acelerador me dice que va desde 1100 a 1940 ... con esas lecturas no deberia tener FS no?
Veamos. Prueba una alargadera para el GPS y una ferrita.
Necesito que me digas el valor de lectura del canal de motor en estos casos

(1) trim abajo y stick abajo
(2) trim arriba y stick abajo
(3) trim arriba y stick arriba

La calibracion de recorrido la haces entre (2) y (3)
Fijas el FS con el (1)
Vuelas entre (2) y (3), es decir con trim arriba.

JT
JuanTrillo esta en línea ahora   Responder Citando
Antiguo 05/06/2012, 20:55   #3226
JLT_GTI
* * *
 
Avatar de JLT_GTI
 
Ingreso 04/dic/2011
465 Mensajes
Cita:
Iniciado por JuanTrillo Ver mensaje
Veamos. Prueba una alargadera para el GPS y una ferrita.
Necesito que me digas el valor de lectura del canal de motor en estos casos

(1) trim abajo y stick abajo
(2) trim arriba y stick abajo
(3) trim arriba y stick arriba

La calibracion de recorrido la haces entre (2) y (3)
Fijas el FS con el (1)
Vuelas entre (2) y (3), es decir con trim arriba.

JT
Gracias

Pues el acelerador arriba al maximo con el trim arriba maximo da 1930 - 1940us (fluctua..con el USB puesto me da muchas interferencias)

Al minimo con trim abajo del todo da 970uS.. acabo de calibrarlos (de paso pasar el servo de timon de la salida AIL a RUD ya que Ikarus usa el timon para girar y los alerones para estabilizar ..por tanto yo tengo que tener la direccion en RUD-OUT para que haga algo no? ) ..
Tras calibrar como tu dices me sale abajo del todo 1100us y arriba 1930..

Donde se fija el failsafe que tu dices? porque no lo veo.
Al entrar en la configuracion de autopilot me salen 2 errores:

-"Error cargando rango servo alerones" (esta puede ser normal porque uso el canal 5 a un switch ya que ese no lo uso y me lo exije para calibrar servos)
y
-"Error cargando configuracion seguridad motor" ..
(nota: no tengo configurado failsafe en el receptor y no tengo pensado hacerlo) No se si tiene que ver pero en autopilot el minimo del acelerador esta puesto 1038 cuando en el asistente da 1100..

Pero ese ahora no es el gran problema.. tengo otro mas gtrande.

Acabo de calibrar el amperimetro y me da lecturas al fin en el OSD...pero erroneas.

Lo calibre como dijiste.. en la casilla 1 puse 10A y en la otra 20 y con un amperimetro conectado cuando lo tenia a 10A fije leer en 1 y a 20A fije leer en la 2.. y grabe.

Pero me salen lecturas de aproximadamente la mitad de lo real..

En el OSD le doy potencia y veo en pantalla 2.2A por ejemplo y en el amperimetro veo 5.6A .. repeti la calibracion fijando a 8 y 15A y me sale lo mismo

Editado por JLT_GTI; 05/06/2012 a las 21:15
JLT_GTI está desconectado   Responder Citando
Antiguo 05/06/2012, 22:00   #3227
rgon
*
 
Ingreso 24/mar/2011
De Lisboa
34 Mensajes
Enviar un mensaje por Skype™ a rgon
Cita:
Iniciado por JuanTrillo Ver mensaje
¿Que es el MWC?

JT

MWC= MultiWiiCopter

El FY_2_IR está conectado a la salida de los siervos de el gimbal de mwc.

En teoría debería funcionar con el mismo principio de un FY. No he dedicado mucho tiempo con los ajustes de ganancia en el MWC, pero creo que puede funcionar correctamente.

En el video no es muy notable, pero usted puede ver lo Ikarus con mwc. Tan pronto como me sea posible voy a hacer un video con mejor calidad.


http://www.youtube.com/watch?v=v0OC8tfZpdo

Editado por rgon; 05/06/2012 a las 22:18
rgon está desconectado   Responder Citando
Antiguo 05/06/2012, 22:15   #3228
JuanTrillo
* * * * * *
 
Avatar de JuanTrillo
 
Ingreso 21/sep/2007
De Bormujos (Sevilla)
4.951 Mensajes
Cita:
Iniciado por JLT_GTI Ver mensaje
Gracias

Pues el acelerador arriba al maximo con el trim arriba maximo da 1930 - 1940us (fluctua..con el USB puesto me da muchas interferencias)

Al minimo con trim abajo del todo da 970uS.. acabo de calibrarlos (de paso pasar el servo de timon de la salida AIL a RUD ya que Ikarus usa el timon para girar y los alerones para estabilizar ..por tanto yo tengo que tener la direccion en RUD-OUT para que haga algo no? ) ..
Tras calibrar como tu dices me sale abajo del todo 1100us y arriba 1930..

Donde se fija el failsafe que tu dices? porque no lo veo.
Al entrar en la configuracion de autopilot me salen 2 errores:

-"Error cargando rango servo alerones" (esta puede ser normal porque uso el canal 5 a un switch ya que ese no lo uso y me lo exije para calibrar servos)
y
-"Error cargando configuracion seguridad motor" ..
(nota: no tengo configurado failsafe en el receptor y no tengo pensado hacerlo) No se si tiene que ver pero en autopilot el minimo del acelerador esta puesto 1038 cuando en el asistente da 1100..

Pero ese ahora no es el gran problema.. tengo otro mas gtrande.

Acabo de calibrar el amperimetro y me da lecturas al fin en el OSD...pero erroneas.

Lo calibre como dijiste.. en la casilla 1 puse 10A y en la otra 20 y con un amperimetro conectado cuando lo tenia a 10A fije leer en 1 y a 20A fije leer en la 2.. y grabe.

Pero me salen lecturas de aproximadamente la mitad de lo real..

En el OSD le doy potencia y veo en pantalla 2.2A por ejemplo y en el amperimetro veo 5.6A .. repeti la calibracion fijando a 8 y 15A y me sale lo mismo
Veamos. Tus tres medidas son.

(1) trim abajo y stick abajo = 970
(2) trim arriba y stick abajo = 1100
(3) trim arriba y stick arriba = 1930

Vuelas con trim arriba y calibras asi, con rango 1100-1930. Fijas FS con trim abajo (1). Al apagar la radio verifica en configurar servos que el canal de motor se va a 970. Si es asi ikarus abrira la pantalla FS y volverá a casita.

Otro tema. Pon cada cosa en su sitio. Direccion en direccion y cola en cola. Ikarus puede ser configurado para que gire solo cola, solo alerones, o ambos.
Tienes completa informacion de los modos en el tutorial enlazado en el primer post.

Amperimetro. Hay que afinarlo. Haz esta prueba. Primera medida con 0A y motor parado. Segunda a 3/4 de motor. Si es de 40A a 30, si es de 20A a 15.
Pruebalo y haz el ajuste "fino" cambiando ligeramente la ganancia del sensor en la entraga "gain" de la ventana autopilot. Te informo que por mucho que digan los fabricantes, no son completamente lineales, pero una diferencia maxima de 1A no esta mal. Tus medidas no son normales. Estoy barajando hacer mas lecturas e interpolar la curva por lo menos en tres puntos. Otra posibilidad es poner la pantalla como un bingo e ir dando motor y marcar la casilla del consumo a medida que vayamos subiendo, pero me parece un poco exagerado.

El campo seguridad motor indica el valor en us de motor parado. Es importante para que la seguridad este siempre activa. Ikarus NUNCA encenderá motor en modo autopilot cuando:

- No haya lectura de gps
- La lectura de gps sea menor que la altura de seguridad

Tras hacer el asistente de servos no debe salir error alguno. Revisalo y recuerda salir del asistente con GUARDAR, sino to es pa ná.

JuanTrillo
JuanTrillo esta en línea ahora   Responder Citando
Antiguo 05/06/2012, 22:18   #3229
JuanTrillo
* * * * * *
 
Avatar de JuanTrillo
 
Ingreso 21/sep/2007
De Bormujos (Sevilla)
4.951 Mensajes
Cita:
Iniciado por rgon Ver mensaje
MWC= MultiWiiCopter

El FY_2_IR está conectado a la salida de los siervos de el gimbal de mwc.

En teoría debería funcionar con el mismo principio de un FY. No he dedicado mucho tiempo con los ajustes de ganancia en el MWC, pero creo que puede funcionar correctamente.

En el video no es muy notable, pero usted puede ver lo Ikarus con mwc. Tan pronto como me sea posible voy a hacer un video con mejor calidad.
Está claro que no tengo multicopteros

F2IR debe funcionar con cualquier estabilizador con salida pwm. Skyworker usa tambien el de una placa multicoptero. openpilot creo, con excelentes resultados.

Igual esa es una alternativa de estabilizacion BBB

JuanTrillo
JuanTrillo esta en línea ahora   Responder Citando
Antiguo 05/06/2012, 23:08   #3230
JLT_GTI
* * *
 
Avatar de JLT_GTI
 
Ingreso 04/dic/2011
465 Mensajes
Cita:
Iniciado por JuanTrillo Ver mensaje
Veamos. Tus tres medidas son.

(1) trim abajo y stick abajo = 970
(2) trim arriba y stick abajo = 1100
(3) trim arriba y stick arriba = 1930

Vuelas con trim arriba y calibras asi, con rango 1100-1930. Fijas FS con trim abajo (1). Al apagar la radio verifica en configurar servos que el canal de motor se va a 970. Si es asi ikarus abrira la pantalla FS y volverá a casita.
No.. 1100 me sale con stick abajo y trim neutral.. trim arriba y stick arriba da 1930 pero no modifica.. creo que tiene que ver con Futaba .. sin embargo stick abajo y trim abajo si da 970..
Al apagar la radio se va a Failsafe bien.. ya lo hacia antes.. lo que queria era asegurarme de que no quede sensible porque en los primeros vuelos si no esta bien afinado el RTH y entra accidentalmente se puede liar..

Vuelvo a preguntar que donde se fija el FS porque no vi esa opcion en la consola (por cierto la consola esta nueva funciona con el Ikarus que me dejo Eladio)


Cita:
Otro tema. Pon cada cosa en su sitio. Direccion en direccion y cola en cola. Ikarus puede ser configurado para que gire solo cola, solo alerones, o ambos.
Tienes completa informacion de los modos en el tutorial enlazado en el primer post.
Puse la cola en RUD-OUT y le dije al asistente que el stick que uso para girar es el timon (en la emisora es alerones para volar con todo a la derecha en modo2).. configurare pues ikarus para que gire solo con timon y nos olvidamos de los alerones (no hay ).. lo que no se es en el futuro cuando tenga estabilizador (si se pone) como se resuelve aqui.. teoricamente con diedro es igual que alerones.


Cita:
Amperimetro. Hay que afinarlo. Haz esta prueba. Primera medida con 0A y motor parado. Segunda a 3/4 de motor. Si es de 40A a 30, si es de 20A a 15.
Pruebalo y haz el ajuste "fino" cambiando ligeramente la ganancia del sensor en la entraga "gain" de la ventana autopilot. Te informo que por mucho que digan los fabricantes, no son completamente lineales, pero una diferencia maxima de 1A no esta mal. Tus medidas no son normales. Estoy barajando hacer mas lecturas e interpolar la curva por lo menos en tres puntos. Otra posibilidad es poner la pantalla como un bingo e ir dando motor y marcar la casilla del consumo a medida que vayamos subiendo, pero me parece un poco exagerado.
Alguien tiene el sensor de 50A por aqui? existe la remota posibilidad de que los valores offset sean similares entre unidades iguales?

Cita:
El campo seguridad motor indica el valor en us de motor parado. Es importante para que la seguridad este siempre activa.
Donde se activa eso?


Y lo de los satelites es un desastre.. no entiendo porque hace un par de meses me detecto 5 satelites rapidamente la primera vez que lo conecte ..con todo conectado y viendo el video a traves del Tx de video ...hace una semana me detecto 3 y luego callo (cuando bajo la bateria de video.. no se si estara relacionado..seguan siendo 9.6V) y hoy nada de nada.. y estas 2 ultimas veces es con el ikarus conectado directo a la capturadora..

Tambien observo muchas interferencias cuando esta el usb conectado.. los servos estan temblequeando.. es desconectar el USB y todo vuelve a la normalidad aunque tampoco me preucupaba mucho porque no se va a volar con el USB puesto...
JLT_GTI está desconectado   Responder Citando
Antiguo 06/06/2012, 16:28   #3231
JuanTrillo
* * * * * *
 
Avatar de JuanTrillo
 
Ingreso 21/sep/2007
De Bormujos (Sevilla)
4.951 Mensajes
Cita:
Iniciado por JLT_GTI Ver mensaje
No.. 1100 me sale con stick abajo y trim neutral.. trim arriba y stick arriba da 1930 pero no modifica.. creo que tiene que ver con Futaba .. sin embargo stick abajo y trim abajo si da 970..
Al apagar la radio se va a Failsafe bien.. ya lo hacia antes.. lo que queria era asegurarme de que no quede sensible porque en los primeros vuelos si no esta bien afinado el RTH y entra accidentalmente se puede liar..

Vuelvo a preguntar que donde se fija el FS porque no vi esa opcion en la consola (por cierto la consola esta nueva funciona con el Ikarus que me dejo Eladio)

Veamos. No hay que configurar FS en ikarus. Ikarus detecta failsafe AUTOMATICAMENTE en funcion del estado en cada instante del valor del canal de motor y el valor almacenado en la casilla MIN(motor). No te va a saltar automaticamente si fijas el recorrido con el minimo 50us por encima
del valor que hayas fijado el FS. No se explicar esto de mas formas distintas.



Puse la cola en RUD-OUT y le dije al asistente que el stick que uso para girar es el timon (en la emisora es alerones para volar con todo a la derecha en modo2).. configurare pues ikarus para que gire solo con timon y nos olvidamos de los alerones (no hay ).. lo que no se es en el futuro cuando tenga estabilizador (si se pone) como se resuelve aqui.. teoricamente con diedro es igual que alerones.

Muy facil. Aviador_a400 lleva estabilizacion y rth solo con direcciones. ¿como? Conectas direccion a la salida alerones. Activas "giro coordinado" y te llevas el deslizante a tope de alerones. Plantas 15º en maximo pitch y 15º en maximo giro de alerones.


Alguien tiene el sensor de 50A por aqui? existe la remota posibilidad de que los valores offset sean similares entre unidades iguales?
Donde se activa eso?

Antes del fin de semana espero tener arreglado los asistentes. Una vez hecho trataré de hacer una recopilacion de amperimetros y parametros recomendados. Al fin y al cabo no son tantos. Dentro de la carpeta "last firmware & console" de dropbox hay muchas configuraciones grabadas. Como sabras, ahora es posible leer los archivos desde la consola, siendo posible consultar distintas configuraciones de RSSI y amperimetro. Solo faltaria saber cual usa cada uno. Si no estas dado de alta en dropbox mandame un MP. Por cierto, para hacer esto es necesaria la ultima version, que permite abrir archivos de configuracion Off-line.



Y lo de los satelites es un desastre.. no entiendo porque hace un par de meses me detecto 5 satelites rapidamente la primera vez que lo conecte ..con todo conectado y viendo el video a traves del Tx de video ...hace una semana me detecto 3 y luego callo (cuando bajo la bateria de video.. no se si estara relacionado..seguan siendo 9.6V) y hoy nada de nada.. y estas 2 ultimas veces es con el ikarus conectado directo a la capturadora..

He cogido un ikarus que tengo en casa medio "sordo" y he alimentado el gps con un bec, usando una Y de alerones a la que le quito el positivo que va a ikarus. Mano de santo. Con lo que consume un gps no me sorprendería que podría valer el propio bec del ESC.


Tambien observo muchas interferencias cuando esta el usb conectado.. los servos estan temblequeando.. es desconectar el USB y todo vuelve a la normalidad aunque tampoco me preucupaba mucho porque no se va a volar con el USB puesto...

Normal. Tambien pasa algunas veces SOLO con W7 que hay que desconectar y reconectar el usb porque se queda en el limbo. Es un problema menor pero que puede suceder por problemas con el driver usb para W7 64bits

JuanTrillo
JuanTrillo esta en línea ahora   Responder Citando
Antiguo 06/06/2012, 17:04   #3232
JLT_GTI
* * *
 
Avatar de JLT_GTI
 
Ingreso 04/dic/2011
465 Mensajes
-Que tan fiables son los contadores de bateria basados en voltaje? Veo que hay 2 tipos.. el que calcula mediante la capacidad de bateria.. y el que calcula mediante el consumo registrado por el amperimetro al que se le debe indicar primero la capacidad en mAh de la bateria y con el consumo ira restando (asumo)..

Porque si el de voltaje es algo fiable podria valer para ir tirando mientras..

-Si se alimenta el GPS desde el BEC del variador (en mi caso es un turnigy plush 30A de modo que el BEC es de 2A lineal..osea no switching) no habria problema de interferencia no? (por lo que dicen que si en FPV no conviene alimentar el video desde el BEC del ESC por interferencias y demas)..

2A supongo que irian suficientes.. en el Escuela el BEC solo alimenta al RX, el modulo PPM (que no se cuanto chupa pero poco asumo dado que en vacio con el amperimetro me daba como 0.1A) 3 servos (uno de ellos pan que no deberia hacer mucho esfuerzo y los otros 2 son microservos que mueven las superficies de un Escuela que son relativamente pequeñas).
JLT_GTI está desconectado   Responder Citando
Antiguo 06/06/2012, 22:31   #3233
JuanTrillo
* * * * * *
 
Avatar de JuanTrillo
 
Ingreso 21/sep/2007
De Bormujos (Sevilla)
4.951 Mensajes
Cita:
Iniciado por JLT_GTI Ver mensaje
-Que tan fiables son los contadores de bateria basados en voltaje? Veo que hay 2 tipos.. el que calcula mediante la capacidad de bateria.. y el que calcula mediante el consumo registrado por el amperimetro al que se le debe indicar primero la capacidad en mAh de la bateria y con el consumo ira restando (asumo)..

Porque si el de voltaje es algo fiable podria valer para ir tirando mientras..

-Si se alimenta el GPS desde el BEC del variador (en mi caso es un turnigy plush 30A de modo que el BEC es de 2A lineal..osea no switching) no habria problema de interferencia no? (por lo que dicen que si en FPV no conviene alimentar el video desde el BEC del ESC por interferencias y demas)..

2A supongo que irian suficientes.. en el Escuela el BEC solo alimenta al RX, el modulo PPM (que no se cuanto chupa pero poco asumo dado que en vacio con el amperimetro me daba como 0.1A) 3 servos (uno de ellos pan que no deberia hacer mucho esfuerzo y los otros 2 son microservos que mueven las superficies de un Escuela que son relativamente pequeñas).
Yo uso siempre el valor de voltaje, una vez bien ajustado, para saber el estado de las baterias. La capacidad podria reducirse, pero siempre el voltaje te va a indicar el autentico estado.

Hay muchos tipos de ESC, los buenos llevan filtros que permiten ahorrarte la bateria de video. Este es mi caso en el skywalker, que lo llevo sobredimensionado, de 80A. Me arriesgo a pensar que su salida de 5v tambien va filtrada. El unico problema es el ruido que los servos aporten a la linea de tierra.

Todo es probar.

JuanTrillo
JuanTrillo esta en línea ahora   Responder Citando
Antiguo 06/06/2012, 22:57   #3234
JuanTrillo
* * * * * *
 
Avatar de JuanTrillo
 
Ingreso 21/sep/2007
De Bormujos (Sevilla)
4.951 Mensajes
nueva consola y firmware 20120606

Actualización 6 de junio de 2012. CONSOLA + OSD

Novedades:
Corregido error en asistentes de voltimetros, amperimetro y rssi.
Corregido instrumento Km/Ah.
Añadido pitch & roll a la comunicación UDP.
Incrementada la altura de seguridad máxima de motor parado hasta 30.000 m.
Necesita actualizar consola y osd.

Enlaces en post#1 de este hilo.

JuanTrillo
JuanTrillo esta en línea ahora   Responder Citando
Antiguo 06/06/2012, 23:09   #3235
ASRASR
* * * * * *
 
Avatar de ASRASR
 
Ingreso 30/may/2008
De MALAGA (Benalmádena)
3.633 Mensajes
Menos mal ya podemos subir a 30.000m sin problemas, que alivio
ASRASR esta en línea ahora   Responder Citando
Antiguo 06/06/2012, 23:11   #3236
JuanTrillo
* * * * * *
 
Avatar de JuanTrillo
 
Ingreso 21/sep/2007
De Bormujos (Sevilla)
4.951 Mensajes
Cita:
Iniciado por ASRASR Ver mensaje
Menos mal ya podemos subir a 30.000m sin problemas, que alivio
Que te cuente Jose Antonio para qué quiere esto.

JuanTrillo
JuanTrillo esta en línea ahora   Responder Citando
Antiguo 07/06/2012, 01:04   #3237
rodjavcc
*
 
Ingreso 12/mar/2008
De Santiago, Chile
94 Mensajes
Juan, la ultima version soporta el Chainlink??,

Lo otro probe los cambios de parametros PID mediante Uplink y pasa lo siguiente:

los parametros pid cuando los cambio, el OSD me avisa, pero no hay efectos (ej cambiar un drive limit de 0.1 a 0,9 lo cual debe ser bastante notorio.)
despues del "flash" y abro el ikarus por usb, los cambios estan guardados, pero no hay cambios de movimiento en la superficie modificada

sin embargo cuando cambio "rumbo ail" y "altitud ele" los cambios se reflejan de inmediato, acuerdate que uso la version 2012.05.10,
¿Juan puedes comprobarlo que a ti se te cambien los drive limit con uplink y con esa version?

Saludos
rodjavcc está desconectado   Responder Citando
Antiguo 07/06/2012, 06:33   #3238
aeromanolete
* * *
 
Avatar de aeromanolete
 
Ingreso 27/sep/2010
De Palma del Río (Córdoba)
309 Mensajes
Hola a todos, tengo una placa de multicopteros, y me gustaria probarla con Ikarus, para lo cual, creo que necesito el cable FY_2_ir, pero ElectronicaRC ya no lo tiene, ¿alguien me podriaq indicar como conseguirlo, o hacerme un esquema para hacermelo?

Gracias.
aeromanolete está desconectado   Responder Citando
Antiguo 07/06/2012, 10:19   #3239
JuanTrillo
* * * * * *
 
Avatar de JuanTrillo
 
Ingreso 21/sep/2007
De Bormujos (Sevilla)
4.951 Mensajes
Cita:
Iniciado por rodjavcc Ver mensaje
Juan, la ultima version soporta el Chainlink??,

Lo otro probe los cambios de parametros PID mediante Uplink y pasa lo siguiente:

los parametros pid cuando los cambio, el OSD me avisa, pero no hay efectos (ej cambiar un drive limit de 0.1 a 0,9 lo cual debe ser bastante notorio.)
despues del "flash" y abro el ikarus por usb, los cambios estan guardados, pero no hay cambios de movimiento en la superficie modificada

sin embargo cuando cambio "rumbo ail" y "altitud ele" los cambios se reflejan de inmediato, acuerdate que uso la version 2012.05.10,
¿Juan puedes comprobarlo que a ti se te cambien los drive limit con uplink y con esa version?

Saludos
La ultima version incluye los anteriores cambios. Voy a mirar lo que me comentas de drive lim, pero me sorprende. Ademas puedes ver la salida de los servos visualmente con el instrumento auxiliar. Aunque aumentes su valor no llegara al maximo dependiendo de los valores PID. Cambia todos los P a 0,1 y simula en casa con el instrumento auxiliar activo en la pantalla habitual. luego lo repito yo.

JuanTrillo

Enviado desde mi GT-I9100 usando Tapatalk
__________________
www.dsrobotics.com
JuanTrillo esta en línea ahora   Responder Citando
Antiguo 07/06/2012, 13:02   #3240
ondebe
* * *
 
Avatar de ondebe
 
Ingreso 10/feb/2012
346 Mensajes
error

Cita:
Iniciado por JuanTrillo Ver mensaje
Os pongo un video donde se observa que tras hacer la calibracion de los voltimetros se corrompen los ajuste de RSSI y ajustes del amperimetro.

Mientras tanto haced los ajustes en este orden:

voltimetros
rssi
amperimetro.

Os dejo el video




JuanTrillo
Lo que me pasaba a mi
ondebe está desconectado   Responder Citando


Herramientas Buscar en Tema
Buscar en Tema:

Búsq. Avanzada

Ir al foro

Temas similares
Tema Autor Foro Resp. Último mensaje
Vendo IKARUS OSD vialdi MERCADO de COMPRA / VENTA 5 28/02/2015 20:57
Vendo Ikarus Osd Nyru MERCADO de COMPRA / VENTA 9 04/07/2014 17:25
Vendo ikarus por 50€ rccomtrolado MERCADO de COMPRA / VENTA 5 21/02/2014 14:25
Ikarus y Cp4 duckcrazy MERCADO de COMPRA / VENTA 7 16/10/2012 16:53
Ikarus OSD + FY-30A marcio_coragem R/C TELEMETRÍA y UAV PROYECTOS 3 21/12/2011 20:11


Tu hora GMT +1. Ahora son las 10:54.


2015