Herramientas Buscar en Tema
Antiguo 22/01/2016, 08:54   #3391
Simba
* * * * * *
 
Avatar de Simba
 
Ingreso 04/jul/2008
4.652 Mensajes
Los envíos de UK suelen tardar una semana +-
Simba esta en línea ahora   Responder Citando
Antiguo 22/01/2016, 09:03   #3392
Simba
* * * * * *
 
Avatar de Simba
 
Ingreso 04/jul/2008
4.652 Mensajes
Una sugerencia, cuando arrancamos al conectar, el tilt se pone de golpe seco a 45º y luego al terminar el arranque se pone a 0º.

¿Se podía eliminar el movimiento de tilt, hasta que ya esté arrancado? o sea que no se mueva hasta que esté en funcionamiento, así evitaríamos esos movimientos bruscos.
Simba esta en línea ahora   Responder Citando
Antiguo 22/01/2016, 10:50   #3393
TURRUK
* * *
 
Avatar de TURRUK
 
Ingreso 04/abr/2012
397 Mensajes
Cita:
Iniciado por rortega Ver mensaje
Perfecto, gracias por buscarlo y pegarlo, así me cuesta menos encontrarlo.

Lo voy a solucionar durante el fin de semana.
Hola Rortega pido disculpa por esto, como dice simba mas facil cambiar el cables de motor de servo olvida te y siga a tu marcha.
TURRUK esta en línea ahora   Responder Citando
Antiguo 22/01/2016, 11:45   #3394
TURRUK
* * *
 
Avatar de TURRUK
 
Ingreso 04/abr/2012
397 Mensajes
Hola de nuevo ya tema solucionado ya funciona, rortega perdon por distraerte.
TURRUK esta en línea ahora   Responder Citando
Antiguo 22/01/2016, 12:07   #3395
carabin
* *
 
Avatar de carabin
 
Ingreso 29/jul/2010
185 Mensajes
Turuck con esos fallos los mirones también aprendemos 👍

Enviado desde mi GT-I9301I mediante Tapatalk
carabin está desconectado   Responder Citando
Antiguo 22/01/2016, 12:25   #3396
TURRUK
* * *
 
Avatar de TURRUK
 
Ingreso 04/abr/2012
397 Mensajes
Thumbs up

Cita:
Iniciado por carabin Ver mensaje
Turuck con esos fallos los mirones también aprendemos 👍

Enviado desde mi GT-I9301I mediante Tapatalk
Ok a veces pasa . "No hay nada malo en cometer errores, lo que está mal es dejar que se quede como un error sin el esfuerzo de hacerlo bien".
TURRUK esta en línea ahora   Responder Citando
Antiguo 22/01/2016, 12:46   #3397
rortega
* * * * * *
 
Avatar de rortega
 
Ingreso 20/abr/2012
3.816 Mensajes
Cita:
Iniciado por Simba Ver mensaje
Una sugerencia, cuando arrancamos al conectar, el tilt se pone de golpe seco a 45º y luego al terminar el arranque se pone a 0º.

¿Se podía eliminar el movimiento de tilt, hasta que ya esté arrancado? o sea que no se mueva hasta que esté en funcionamiento, así evitaríamos esos movimientos bruscos.
Sí, se puede eliminar.
__________________
WiiFPV Team: VIMEO - YouTube
rortega esta en línea ahora   Responder Citando
Antiguo 22/01/2016, 20:56   #3398
Guillesan
* * * * * *
 
Avatar de Guillesan
 
Ingreso 31/oct/2008
De Barcelona
1.967 Mensajes
Como uno no tiene Flip32 se entretiene probando la antena con el simulador GPS

ArduinoMega
Gps_Telemetry
Amv 360 v0,9




Guillesan esta en línea ahora   Responder Citando
Antiguo 23/01/2016, 00:22   #3399
rortega
* * * * * *
 
Avatar de rortega
 
Ingreso 20/abr/2012
3.816 Mensajes
Cita:
Iniciado por Guillesan Ver mensaje
Como uno no tiene Flip32 se entretiene probando la antena con el simulador GPS
Que bien funciona eso...tienes que ser la envidia del personal cuando andas por el campo de vuelo.
__________________
WiiFPV Team: VIMEO - YouTube
rortega esta en línea ahora   Responder Citando
Antiguo 23/01/2016, 00:26   #3400
rortega
* * * * * *
 
Avatar de rortega
 
Ingreso 20/abr/2012
3.816 Mensajes
Ya he encontrado el fallito del easing, me ha costado unas cuantas horas averiguar el problema, pero al final lo he soluiconado.

He subido el firm: https://github.com/raul-ortega/amv-o...acker_NAZE.hex

Simba, no he sido capaz de impedir que se muevan los servos la inicio, o yo estoy equivocado, o me temo que simplemente por aplicar tensión los servos se mueven. Mañana por la mañana, con la mente más lúcida, lo volveré a mirar.

Turruk, lo de la inversión del servo lo pienso mañana con tranquilidad, aunque no es algo que me parezca demasiado complicado implementar.

En cuanto a parámetros no hay cambios, todo sigue igual.
__________________
WiiFPV Team: VIMEO - YouTube
rortega esta en línea ahora   Responder Citando
Antiguo 23/01/2016, 00:37   #3401
rortega
* * * * * *
 
Avatar de rortega
 
Ingreso 20/abr/2012
3.816 Mensajes
En cuanto al easing se me ha olvidado comentar que he realizado una modificación en el código que debería de mejorar el comportamiento del servo pan, en el sentido de que ahora hay más tiempo de procesador dedicado al servo pan.

Antes, en cada uno de los pasos del efecto easing se hacía un delay de 15 milisegundos. Eso implicaba que durante esos 15 milisegundos el microprocesador se quedaba esperando sin hacer nada. Ahora ya no es así, ahora lo que hago es que en lugar de dar un paso de tilt y quedarme quieto esperando, continúo ejecutando código, y entre las instrucciones llevo un contador de tiempo, cada vez que cuento 15 milisegundos, aplico el siguiente paso de tilt, y así sucesivamente hasta que no me quedan más pasos de tilt que dar...no sé si me habré explicado bien...

La ventaja que tiene ésto es que se comprueba con más frecuencia si ha habido cambios en el heading, con lo cual el control de PIDs tiene más información con la que trabajar, ofreciendo resultados más precisos.

Debería notarse pues un movimiento menos discontínuo, más fluído. Evidentemente ese movimiento va a depender también de la frecuencia con la que se reciban datos de telemetría.
__________________
WiiFPV Team: VIMEO - YouTube
rortega esta en línea ahora   Responder Citando
Antiguo 23/01/2016, 00:39   #3402
rortega
* * * * * *
 
Avatar de rortega
 
Ingreso 20/abr/2012
3.816 Mensajes
No sé si mañana será alguno capaz de probar ésto en el campo.
__________________
WiiFPV Team: VIMEO - YouTube
rortega esta en línea ahora   Responder Citando
Antiguo 23/01/2016, 00:57   #3403
Simba
* * * * * *
 
Avatar de Simba
 
Ingreso 04/jul/2008
4.652 Mensajes
Simba, no he sido capaz de impedir que se muevan los servos la inicio, o yo estoy equivocado, o me temo que simplemente por aplicar tensión los servos se mueven. Mañana por la mañana, con la mente más lúcida, lo volveré a mirar.

Si esto también lo había pensado yo, en algunas ocasiones ya lo había experimentado con los aviones, incluso con los servos de cíclico de un helicóptero, no en todos los casos pero en algunos sucede lo mismo, que al conectar los servos tienden a desplazarse al limite.

Yo lo suponía a características del arranque de los Rx, que primero y hasta que el procesador no termina de arrancar, a los servos ya les esta llegando alimentación, y la señal es totalmente aleatoria.
Quizá si se pudiera condicionar la salida PPM, dijéramos innibiendola, el servo ante la no presencia de señal, no se mueve (creo, no estoy seguro tendría que probarlo).

Incluso me plantee el meter un interruptor independiente, para la tensión de servos, y que accionaria después de haber arrancado el interruptor principal.
Lo que no entiendo es el porque hay otros Rx, que este problema no lo presentan, es como si gestionaran la tensión de servos o la señal, en fin no lo termino de entender.
O igual el problema no es de los Rx o de la Placa de control, y es de los propios servos que tienen esta característica.

sl2
Simba esta en línea ahora   Responder Citando
Antiguo 23/01/2016, 01:00   #3404
rortega
* * * * * *
 
Avatar de rortega
 
Ingreso 20/abr/2012
3.816 Mensajes
Yo creo recordar que en mi Raptor, cada vez conecto la batería los servos de los alerones y timones de cola se mueven a la posición central.
__________________
WiiFPV Team: VIMEO - YouTube
rortega esta en línea ahora   Responder Citando
Antiguo 23/01/2016, 01:11   #3405
rortega
* * * * * *
 
Avatar de rortega
 
Ingreso 20/abr/2012
3.816 Mensajes
He dejado un vídeo subiendo, tardará unos minutos en estar disponible.

En la primera parte está trabajando con el protocolo MFD, usando el simulador que me creé. Como se vé, el movimiento es bastante fluido.

Una vez acaba en el Norte tras haber bajando el tilt, desde el hercules le doy la orden de cambiar a protocolo GPS_TELEMETRY, y le inyecto las tramas del simulador NMEA. Intento hacer pasadas sobre la vertical y tal para ver como se comporta.

Para mí ahora, desde que está con la versión de 32 bits, me parece que va todo como más fluído. En el caso del GPS_TELEMETRY no lleva mucha continuidad porque voy completamente en manual y por los problemas del simulador, que no lo podemos mandar las tramas a la frecuencia que deseemos.

__________________
WiiFPV Team: VIMEO - YouTube
rortega esta en línea ahora   Responder Citando
Antiguo 23/01/2016, 08:46   #3406
TURRUK
* * *
 
Avatar de TURRUK
 
Ingreso 04/abr/2012
397 Mensajes
Cita:
Iniciado por rortega Ver mensaje
Ya he encontrado el fallito del easing, me ha costado unas cuantas horas averiguar el problema, pero al final lo he soluiconado.

He subido el firm: https://github.com/raul-ortega/amv-o...acker_NAZE.hex

Simba, no he sido capaz de impedir que se muevan los servos la inicio, o yo estoy equivocado, o me temo que simplemente por aplicar tensión los servos se mueven. Mañana por la mañana, con la mente más lúcida, lo volveré a mirar.

Turruk, lo de la inversión del servo lo pienso mañana con tranquilidad, aunque no es algo que me parezca demasiado complicado implementar.

En cuanto a parámetros no hay cambios, todo sigue igual.
Hola, nada olvida te esto , todo bien ,funciona de marávia
TURRUK esta en línea ahora   Responder Citando
Antiguo 23/01/2016, 08:53   #3407
rortega
* * * * * *
 
Avatar de rortega
 
Ingreso 20/abr/2012
3.816 Mensajes
A ver si llega el OLED y le metemos mano.

Durante el fin de semana intentaré dejar a punto mavlink.
__________________
WiiFPV Team: VIMEO - YouTube
rortega esta en línea ahora   Responder Citando
Antiguo 23/01/2016, 09:10   #3408
Simba
* * * * * *
 
Avatar de Simba
 
Ingreso 04/jul/2008
4.652 Mensajes
Una reflexión sobre lo comentado del movimiento de servo en el arranque.
¿ Porque sólo lo hace el servo de Tilt y en cambio el pan no lo hace ?
Alguna diferencia debe de haber y esa es la causa.
Mira a ver como se trata la salida de señal en los dos casos.
Simba esta en línea ahora   Responder Citando
Antiguo 23/01/2016, 09:22   #3409
rortega
* * * * * *
 
Avatar de rortega
 
Ingreso 20/abr/2012
3.816 Mensajes
Cita:
Iniciado por Simba Ver mensaje
Una reflexión sobre lo comentado del movimiento de servo en el arranque.
¿ Porque sólo lo hace el servo de Tilt y en cambio el pan no lo hace ?
Alguna diferencia debe de haber y esa es la causa.
Mira a ver como se trata la salida de señal en los dos casos.
A mí me lo hacen los dos servos.
__________________
WiiFPV Team: VIMEO - YouTube
rortega esta en línea ahora   Responder Citando
Antiguo 23/01/2016, 09:30   #3410
Simba
* * * * * *
 
Avatar de Simba
 
Ingreso 04/jul/2008
4.652 Mensajes
Pues a mi solo el de Tilt y es más en el otro Traker con la Crius no lo hace ninguno. Es por eso que me ha llamado la atención.
Voy a probar otra vez con la Crius y me asegúrate.
Simba esta en línea ahora   Responder Citando
Antiguo 23/01/2016, 09:44   #3411
rortega
* * * * * *
 
Avatar de rortega
 
Ingreso 20/abr/2012
3.816 Mensajes
Cita:
Iniciado por Simba Ver mensaje
Pues a mi solo el de Tilt y es más en el otro Traker con la Crius no lo hace ninguno. Es por eso que me ha llamado la atención.
Voy a probar otra vez con la Crius y me asegúrate.
.

Tengo que mirar a fondo si tiene algo que ver la forma en la que se manegan los puertos de entrada salida GPIO. Hay un punto en el que se le mandan a los servos sus respectivos pulsos por defecto, pero ya lo desactivé del código, y comenté también otras partes del código sospechosas de hacerlo. Quizás hay algo por ahí escondido que no he visto.
__________________
WiiFPV Team: VIMEO - YouTube
rortega esta en línea ahora   Responder Citando
Antiguo 23/01/2016, 09:49   #3412
Simba
* * * * * *
 
Avatar de Simba
 
Ingreso 04/jul/2008
4.652 Mensajes
Ok, el tema es más importante de lo que parece, ya que sobre todo cuando se montan antenas +- grandes, la mecánica sufre mucho con las sacudidas.
Simba esta en línea ahora   Responder Citando
Antiguo 23/01/2016, 09:55   #3413
rortega
* * * * * *
 
Avatar de rortega
 
Ingreso 20/abr/2012
3.816 Mensajes
Cita:
Iniciado por Simba Ver mensaje
Ok, el tema es más importante de lo que parece, ya que sobre todo cuando se montan antenas +- grandes, la mecánica sufre mucho con las sacudidas.
Sí, soy consciente...
__________________
WiiFPV Team: VIMEO - YouTube
rortega esta en línea ahora   Responder Citando
Antiguo 23/01/2016, 10:37   #3414
rortega
* * * * * *
 
Avatar de rortega
 
Ingreso 20/abr/2012
3.816 Mensajes
Eureka!!!! Lo encontré !!!

A parte de el "initServos" que hace el código del tracker, hay un punto en el que se resetea la configuración a valores por defectos, que sucede justo en el arranque, antes de llegar al código que realmente maneja el tracker. En ese punto se ponen todos los servos a 1500, de ahí que se muevan.

Ahora la pregunta del millón ¿Eliminamos el initServos() del código del tracker?

Ésto lo que realmente hace es colocar los servos en el centro según lo tengamos configurado por defecto. Pero la primera vez tras subir el firm, cuando aún no tenemos los parámetros ajustados a nuestros valores buenos, sí que se moverían. Pero una vez configurados ya no se volverían a mover, salvo el tilt que depende donde se haya quedado cuando quitamos la alimentación. Pero si tiene el easing activado, no debería ser un problema porque bajaría al cero amortiguando.

Lo que voy a hacer es poner un parámetro en la configuración para activar/desactivar el inicio de servos. Por defecto lo voy a poner desactivado, así nadie se lleva un susto si recarga el firm con la antena puesta. ¿Qué os parece? Es algo que no me va a llevar más de 15 minutos implementarlo.
__________________
WiiFPV Team: VIMEO - YouTube
rortega esta en línea ahora   Responder Citando
Antiguo 23/01/2016, 10:52   #3415
rortega
* * * * * *
 
Avatar de rortega
 
Ingreso 20/abr/2012
3.816 Mensajes
Bueno, ya está implementado y subido.

El parámetro es:

set init_servos=1 para que los servos se pongan en su posición de inicio durante el arranque.

set init_servos=0 para que los servos se queden quietecitos hasta que no empiece el baile de la telemetría.
__________________
WiiFPV Team: VIMEO - YouTube
rortega esta en línea ahora   Responder Citando
Antiguo 23/01/2016, 14:08   #3416
Guillesan
* * * * * *
 
Avatar de Guillesan
 
Ingreso 31/oct/2008
De Barcelona
1.967 Mensajes
Cita:
Iniciado por rortega Ver mensaje
Eureka!!!! Lo encontré !!!

A parte de el "initServos" que hace el código del tracker, hay un punto en el que se resetea la configuración a valores por defectos, que sucede justo en el arranque, antes de llegar al código que realmente maneja el tracker. En ese punto se ponen todos los servos a 1500, de ahí que se muevan.

Ahora la pregunta del millón ¿Eliminamos el initServos() del código del tracker?

Ésto lo que realmente hace es colocar los servos en el centro según lo tengamos configurado por defecto. Pero la primera vez tras subir el firm, cuando aún no tenemos los parámetros ajustados a nuestros valores buenos, sí que se moverían. Pero una vez configurados ya no se volverían a mover, salvo el tilt que depende donde se haya quedado cuando quitamos la alimentación. Pero si tiene el easing activado, no debería ser un problema porque bajaría al cero amortiguando.

Lo que voy a hacer es poner un parámetro en la configuración para activar/desactivar el inicio de servos. Por defecto lo voy a poner desactivado, así nadie se lleva un susto si recarga el firm con la antena puesta. ¿Qué os parece? Es algo que no me va a llevar más de 15 minutos implementarlo.
me parece bien que cada uno escoja.
Init o no init
Guillesan esta en línea ahora   Responder Citando
Antiguo 23/01/2016, 15:49   #3417
Simba
* * * * * *
 
Avatar de Simba
 
Ingreso 04/jul/2008
4.652 Mensajes
Por mi Ok?, ya comento cuando lo pruebe.
Simba esta en línea ahora   Responder Citando
Antiguo 23/01/2016, 17:20   #3418
Simba
* * * * * *
 
Avatar de Simba
 
Ingreso 04/jul/2008
4.652 Mensajes
Bueno ya he probado y parece que hay algún problema.

En modo CLI todo manda bien, con las 2 posiciones de set init_servos.

Cundo paso a modo simulador telemetria, en el momento que le mando Telemetria, se vuelve loco y empieza a oscilar y tener movimientos erráticos.

Lo he probado con set init_servos a 0 y a 1, y hace lo mismo.

En modo CLI si que va bien y hace lo que se supone debe de hacer, al conectar la alimentación, el Pan se mueve un poquito, y el Tilt se queda quieto en su posición con 0, y se mueve a posición 0 con 0.

Es solo en Telemetria que se vuelve majara.
Simba esta en línea ahora   Responder Citando
Antiguo 23/01/2016, 17:29   #3419
rortega
* * * * * *
 
Avatar de rortega
 
Ingreso 20/abr/2012
3.816 Mensajes
Cita:
Iniciado por Simba Ver mensaje
Bueno ya he probado y parece que hay algún problema.

En modo CLI todo manda bien, con las 2 posiciones de set init_servos.

Cundo paso a modo simulador telemetria, en el momento que le mando Telemetria, se vuelve loco y empieza a oscilar y tener movimientos erráticos.

Lo he probado con set init_servos a 0 y a 1, y hace lo mismo.

En modo CLI si que va bien y hace lo que se supone debe de hacer, al conectar la alimentación, el Pan se mueve un poquito, y el Tilt se queda quieto en su posición con 0, y se mueve a posición 0 con 0.

Es solo en Telemetria que se vuelve majara.
Eso es porque estás en protocolo MFD
__________________
WiiFPV Team: VIMEO - YouTube
rortega esta en línea ahora   Responder Citando
Antiguo 23/01/2016, 17:30   #3420
Simba
* * * * * *
 
Avatar de Simba
 
Ingreso 04/jul/2008
4.652 Mensajes
Por si sirve de algo, en esta versión cuando arranca se queda encendido el led azul y el rojo, la he cargado 2 veces por si era eso, pero siempre hace lo mismo.
Simba esta en línea ahora   Responder Citando


Herramientas Buscar en Tema
Buscar en Tema:

Búsq. Avanzada

Ir al foro

Temas similares
Tema Autor Foro Resp. Último mensaje
Ayuda! antena tracker darylkorn R/C Antenas, Emisores, Receptores y Comunicaciones 0 14/04/2015 10:25
Opiniones antena tracker mdf o rv antoniobernal R/C Antenas, Emisores, Receptores y Comunicaciones 7 14/07/2014 10:34
Busco antena tracker duckcrazy MERCADO de COMPRA / VENTA 0 15/06/2012 08:45
Opiniones Recomendarme un Antena Tracker jonpeter R/C Antenas, Emisores, Receptores y Comunicaciones 3 06/05/2012 20:30


Tu hora GMT +1. Ahora son las 15:14.


2015