Herramientas Buscar en Tema
Antiguo Ayer, 21:05   #3181
rortega
* * * * * *
 
Avatar de rortega
 
Ingreso 20/abr/2012
5.299 Mensajes
Lo que está ocurriendo es que se ha modificado el código fuente de iNav para poder mapear los canales ADC. Ayer no llegué a cargar el firmware, lo voy a intentar esta noche. "Creo" que desde el configurador se pueden reasignar los canales disponibles en cada placa. En el caso de la omnibus f3, en esta versión hay 3 canales, uno para el vbat, otra para el amperímetro y un tercero para el RSSI. Imagino que se puede reasignar el rssi al airspeed, y meter el rssi vía PPM para poder disfrutar de las 4 funciones. Pero odo eso "CREO", porque realmente no lo he probado aún.

Editado!
__________________
WiiFPV Team: VIMEO - YouTube
rortega esta en línea ahora   Responder Citando
Antiguo Ayer, 21:05   #3182
Simba
* * * * * *
 
Avatar de Simba
 
Ingreso 04/jul/2008
6.125 Mensajes
Supongo que es cuestión de esperar un poco, seguro que en breve lo documentan, con mas claridad en la Wiki, y algo saldrá en RCgroups.

Y espero que nos sirva para las F3.
Simba esta en línea ahora   Responder Citando
Antiguo Ayer, 21:15   #3183
Simba
* * * * * *
 
Avatar de Simba
 
Ingreso 04/jul/2008
6.125 Mensajes
Nos hemos cruzado en el mismo minuto.

Yo lo del rssi que para ti era un problema, ya lo solucione vía PPM con el Orange, y lo que si he visto en el configurador nuevo, que se ve que a mi, se me actualiza solo, es que ya reconoce los últimos sensores Flow, Sonar y Speed.
Simba esta en línea ahora   Responder Citando
Antiguo Ayer, 21:28   #3184
rortega
* * * * * *
 
Avatar de rortega
 
Ingreso 20/abr/2012
5.299 Mensajes
Por defecto el airspeed lo pone en el canal 0 si no está asignado.

Enviado desde mi HUAWEI VNS-L31 mediante Tapatalk
__________________
WiiFPV Team: VIMEO - YouTube
rortega esta en línea ahora   Responder Citando
Antiguo Ayer, 23:22   #3185
rortega
* * * * * *
 
Avatar de rortega
 
Ingreso 20/abr/2012
5.299 Mensajes
Ya he podido cargar el firmware. Parece que la configuración de la 1.7.1 se la traga, pues no uso servo mix.

El pitot supuestamente se detecta automáticamente y por defecto va al canal ADC 0, pero no me preguntéis dónde está situado en la OMNIBUS F3.

La forma de reasignar los canales ADC es mediante comandos CLI. Los valores por defcto son:

vbat_adc_channel = 1
rssi_adc_channel = 3
current_adc_channel = 2
airspeed_adc_channel = 0

Falta aclarar si lo que dice en la documentación sobre que el RSSI no está soportado en la placa es o no cierto: https://github.com/iNavFlight/inav/b...-%20OMNIBUS.md
__________________
WiiFPV Team: VIMEO - YouTube
rortega esta en línea ahora   Responder Citando


Herramientas Buscar en Tema
Buscar en Tema:

Búsq. Avanzada

Ir al foro

Temas similares
Tema Autor Foro Resp. Último mensaje
Navegación FPV José Gil Donat R/C Vuelo en Primera Persona FPV 158 03/04/2017 18:53
Naze32, tricopter y cleanflight 1.11 chusator NAZE32 2 18/01/2016 19:04
Ayuda! Problemas CC3D con Cleanflight jupami MicroMultis 3 11/12/2015 08:47
Autotune pids con cleanflight Mikel369 MicroMultis 8 03/09/2015 12:07
Ayuda! Duda configuración en cleanflight ojuanan General - Proyectos multirrotor 5 13/07/2015 23:15


Tu hora GMT +1. Ahora son las 01:33.


2015